Issue with update? Numerous failures with all chips across the board

I have numerous devices from Particle going back to the Photon up through the Boron. I mainly use the Argon and have purchased quite a few of these. The various utilized devices are setup on bread boards and I had left each on in a state as a functioning prototype circuit ready to be hardwired to a circuit board. One of these prototype devices had used an Argon with an attached 16x2 LCD screen setup via I2C. This was functioning perfectly. I liked this device because it was plug and play so to speak two wires for data/clock and one ground, one 3.3v. Worked out of the box like a charm. I bit expensive if I was to mass produce but for prototyping, fantastic. This prototype had buttons to control values and allowed me to navigate through various displayed menus. I plugged in this working prototype and the screen no longer worked. I assumed that a wire must have become unplugged but I figured I would validate it’s functionality first, so I hooked this up separately, on it’s own breadboard with only this device and an Argon connected. It still did not work. SerLCD
As you can see here, this is a no brainer, two wire connection. Assuming something went wrong with the LCD I broke a brand new one out and connected it, and it too did not function. So now, since there is only one other device in this circuit, I swapped out the Argon for another Argon, downloaded working code that I had use previously, screen still fails. I download and use an I2C address finder, says there are no I2C devices attached. I open up my command prompt to debug, type in ‘particle serial monitor --follow’ as I have probably a thousand times by now’, does an update, says there are no devices attached to the PC… and this device is plugged into the PC and getting power from the PC-USB. I find, download, and install new version of CLI (which is supposed to install drivers during install)… still says no device attached. Look in device manager and I no longer have a com port when this device connects. I can plug ANY particle into this PC and it does not attach a corresponding com port. All of this worked at one time and I had utilized it, on this same computer, hundreds if not thousands of times. This is a lot of errors post program updates. CLI update. Chip update. Does anyone know what the hell is going on here? I2C fails, CLI fails, port creation fails.

Try a different USB cable. I’ve had the same issue when using USB extension or just a low quality cable.

1 Like

That fixed the debug CLI / Com Port creation issue. It was only one cable of the four tried (4th was the last on tried) worked. At least that issue is addressed!! Now on to why the I2C fails to see any devices.
The I2C still does not see and devices on the bus so still not a full solution but thanks for a partial solution to numerous issues.

Do you have pullup resistors in the circuit?

@Mjones makes a good point. Usually, Sparkfun identifies the pull-up resistors in their products. But, I could not find it described for product-16397. However, here is a review posted for a similar product-16396:

For non-Arduino users: CONS: There is one MAJOR downside. This LCD has pull-up resistors… Now that doesn’t seem that bad, but if your microcontroller has pull-up resistors as well, you most likely need to remove them from this board. There is no documentation on which resistors are the pull-up resistors and which jumper they are connected to. I would put that here but for fear of iterating designs, I will let you look through the forums at the time of your purchase. It’s frustrating to get a product and have to run around with a multimeter trying to find the pull-up jumper that should just have been labeled in the first place, or at least in the documentation.

1 Like

Thanks for the advice, much appreciated. Fortunately, the pull-up resistor was not the issue. I had to take each LCD and reset them by tying RX to ground. Power them up for a few seconds, power down, then remove the grounded RX pin. I am not sure why the update caused this issue or why I couldn’t get a brand new LCD to be seen by I2C until it too was reset, but it is good to know now before I mass produced this prototype. I will have to wire this reset method into the existing circuitry and code for it just in case of future updates that ‘tank’ the device. Thank you all for your valuable input… you spent your free time to advise a total stranger. Such magnanimous endeavors, make this would a better place to live. Much, mucho, un beaucoup, viel, Muito de, tanto, thanks!!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.