Is vector supported?

I checked documentation for vector: nothing. Tried to the below code. Compiles without error. It also worked a few times and printed the results as intended whenever I reset Photon. But the last time Photon continuously reset itself in a way that I had to factory reset it. Is there a way to use vector?

#include <vector>
std::vector<byte> v(2);

void setup() {


for (int i; i<5; i++){
    Serial.println( );
    void loop() {}

The STL containers are supported fully when compiling for the Photon/P1 (0.4.x). When compiling against the Core (0.3.4) you need to…take some less than subtle hacks to the Arduino macros…

#include "application.h"
#undef min
#undef max
#include <vector>

(In 0.4.x min/max are no longer macros and so don’t interfere with std::min);

All features of C++11 are supported with the exception of exceptions (eh?) and RTTI.

I had the last fw installed but the above code did’t work. Now I have a big issue:I factory reset Photon and it blinks blue, But when I try to claim it using app:
1- first time I click on Photon name, it asks to change owner.
2- finds wifi network.
3- enter password
4- cofigures wifi. OK
5- connecting to wifi. OK
6- ERROR! … couldn’t configure wifi credentials …
7- I press reset. now Photon blinks blue a second and then resets itself continuosly! :tired_face:
What should i do?

I updates CLI and then Photon in DFU mode. Then tried to connect to Photon by app. exactly the same issues happen :worried: Is photon HW damaged?