Influxdb Webhooks


I’ve been struggling pushing data to my Influxdb server (hosted on EC2) following step-by-step this tutorial :

Here is my “JSON DATA” field:
Capture d’écran 2020-03-20 à 17.50.54

And here is the test event I’m using in the console to trigger Webhooks:
Capture d’écran 2020-03-20 à 18.47.00

Unfortunately I’m getting error 400 all the time.

Do you have an idea of what could be wrong? Is there any way I can get logs of the request/payload sent to Telegraf, or any other solution to get a more explicit description of the error?

Thanks a lot for help!

Hwy @gazo, thanks for posting, and welcome to the Particle community!

Can you post a screenshot or paste of the error you’re getting in the integrations console?

Of course! There it is:

Thank you,

1 Like

Hey @gazo, thanks!

It looks like you’re missing the “influx_db” from the event payload, which should point to your InfluxDB name. Also, do you have the following at the end of the url? :1619/particle

Adding “influx_db” to the payload solved the problem.

By the way, the snapshots and code provided in the tutorial ( are inconsistent, if it can help.

Many thanks!

1 Like

Glad to hear that @gazo! And good point, I will make a note to get this doc fixed.

3 months, still not updated…

4 months…

@bsatrom is not with Particle anymore and I don’t know who may have taken over responsibility for updating that.


Let me ping the appropriate folks to make the change, but are you willing to provide a bit more detail about:

“By the way, the snapshots and code provided in the tutorial […] are inconsistent, if it can help.”

1 Like

From here:


is different to this:

The webhooks section of the console also seems to have a lot more options now than when this tutorial was written, so perhaps a quick update of all of the sections here would be great.

I have also posted a new request here, as after months of trying I am still getting nowhere with this… It has to be a simple fix, I just cant find it…

Help me Obi-wan, you’re my only hope.

1 Like

While at it, there is also an inconsistent number of curly braces in that line :wink:

yeah, exactly. The QA on some of this documentation is lacking honestly. When can we get an updated tutorial for the influxDB? I am using UDP, but that’s far from suitable when there is a webhook alternative.

In the meantime, could one of you please help with my issue here. It’s getting to the point where I may just be better to move to a different platform of microcontroller.


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.