Events not getting published through local cloud

Hi !

I recently created my local cloud it works great but when I am trying to publish one event it is not getting published.

Here is the curl command it keeps listening but nothing happens:

curl -H “Authorization: Bearer 675db2ed24cbfcad5b1128c0e94dc5f1eed99427”

I tried flushing the tinker app as well as cc3000 but still no luck.

Below is the local server response - - [Wed, 10 Dec 2014 05:52:06 GMT] “GET /v1/devices/54ff70066667515155341567/events/light HTTP/1.1” 200 - “-” "curl/7.37.1" - - [Wed, 10 Dec 2014 05:53:34 GMT] “GET /v1/devices/54ff70066667515155341567/events/light/ HTTP/1.1” 200 - “-” “curl/7.37.1”

Any advice?

Use the general /events url and watch for all events. The filter doesn’t seem to work in the local :cloud:

I tried without filter but no luck:

curl -H “Authorization: Bearer 675db2ed24cbfcad5b1128c0e94dc5f1eed99427”


can you try spark subscribe on your command line?

That is the next step I am trying now. Thanks for help.

No success.

spark subscribe light 54ff70066667515155341567
Subscribing to “light” from 54ff70066667515155341567’s stream
Listening to: /v1/devices/54ff70066667515155341567/events/light

Nothing happens.


@satendra4u, i mentioned previously that the command to use will be spark subcribe :wink:

Done and working . Thanks !

Is there any tutorials where I can see which functionalities does work and does not work for spark cloud vs local cloud. This will really help me.


It’s documented here

but most comes from my personal experience using it :wink:

Ok. Let me go through it.


I made pull requests to solve this problem