Events are publishing well and time stamps scroll but no colors associated with events

I have tried in both Firefox and Chrome, but I get this…

The event data seems to be coming through just fine, but there is no “Logs” text at the top of the page nor Key for the event names on the upper right…

Snippet of code…
// Publish data
Particle.publish(“temperature”, String(random(100, 200)));// + " °C");
Particle.publish(“humidity”, String(random(50, 100)));// + “%”);
Particle.publish(“light”, String(random(50, 60) ));// + “%”);
pirSensor(); // motion sensor information
Particle.publish(“ultraviolet”, String(random(10, 50)));
// uvSensor(); // ultraviolet sensor information
// Particle.publish(“time”, Time.timeStr());
// Particle.publish(“time”, String(;
// delay(t);
// delay(t);
// Particle.function(“led”,ledControl);

Its possible that you describe more in detail whats your problem is and provide us with more code then this snippet to follow what happened? Could a subscribe-function to help you a bit further?
I suggest a tutorial from the maker kit, which explains a bit with temp/humidity and publishing.

Certainly Postler. The first image below is a screenshot of what I get… note the absence of any scrolling colored blocks in the event log field. Also note that there is not any text in the upper left portion of the window that shows “Logs”

Next is a screenshot of what I see most typically in other live examples that I see from others. You can see the static image of scrolling colored blocks and the text at the left of the screen showing “Logs” in the event viewer.

If anyone knows the specifics of why one instance of the event viewer would show these two features working while another does not, that would be greatly appreciated.

I will research the difference between publish and subscribe functions. My first step is the need to understand why my instance of the same code as used by another user scrolls the event data in visual format, while mine does not. I am able to retrieve the temp and humidity data and capture it as shown in the event data itself as it scrolls newest data on top and pushes the previous data down the list. It is the interface with the Event viewer (logs) view of the Console that I would like to solve before diving deeper.

The red dots show a restart of the device after the period of time for publishing has decreased (from 6 seconds to 2 seconds). Have you already tried to do without the delay(t)?

The Particle.subscribe() statements have no impact on the console display and the Particle.publish() statements obviously work otherwise you’d not get the event enties in the bottom list.

So I’d suspect something in the browser going wrong.
Have you made sure you have the most recent versions of your browsers?
After that, can you have a look at the browser log console (e.g. F12 for Chrome) and maybe post the output?

ScruffR seems to be on the same track as what I think I am seeing. It is established already that the data is coming in, and being recognized by the browser window otherwise the data events would not be scrolling down in chronological order as the next event comes in via the Particle.Publish() statement. The events are even scrolling at the top of the page from right to left in the same chronological order as they scroll from top to bottom in the section below the event log viewer (for lack of a better or correct term for the “Logs” section within the viewport).

The only thing that is not appearing is the representation of the data in my browser (Firefox 54.0.1 32-bit up to date since last week) as colored blocks in that scrolling field at the top of the page, nor is there a color coded “key” for the events which are being published to the Particle Console. This indicates a possible problem with my browser, or other windows 10 configuration. It seems like from the discussion so far that no-one points to a higher priced version of the Particle Console that is available with more expanded features so I am guessing that is not part of the problem. I was hoping that someone may have been aware of a console configuration or settings sections to enable this.

Shown below is what I am seeing in my Firefox console log. This is not an area that I am familiar with.
window after F12:

I do not have any pop-up blockers enabled but would not be surprised if Windows was somehow culling something out, but I still may not be looking in the right place within my Firefox console log as I am not seeing a stream of data anywhere. I will try running this in an up to date Chrome experience and report back.

Thanks so much ScruffR.

Hmmm… this is the only thing that I see in the console section of Chrome and both of these look like errors as the vendor link is definitely a console that shows ms-stream and moz-chunked-arraybuffer are not playing well:

But diving deeper we get something showing how the canvas is interacting with what it is getting:

I also keep coming back to this fundamental difference which seems more like a configuration issue with Where my


has “Events” as the text instead of every single other instance I have ever seen which shows “Logs” followed by two icons. Could it have been some sort of install I did somewhere along the way?

How about that section has been marked either by you or an overzealous filter as an advert by an adblock plugin?

Thanks for the reply Vishacha. That is one possibility which I am not able to determine if that is occurring or not. Are you able to suggest any specific places within Chrome, Firefox and Windows 10 to look for this occurring?

As you can see in the attached picture, I no not have pop-ups blocked while trying to display the scrolling events. Additionally, there is never any indication given by either browser that a pop-up was blocked or is asking for permission. It is my understanding that the event scroller does not call up a separate window so while it is still possible, this theory has yet to bear any fruit in solving the problem.

Thanks for contributing. I hope that you might have some insight into how a pop-up might be at play here if that is what is happening.

Thanks again!!

OK guys… just an update. I have not made any changes whatsoever to my code, not made any updates either and everything is coming through swimmingly.

I wish I knew the underlying reason why it did not work until now, but I’ll be satisfied with having it work in the meantime. Thanks for all the help !!