ETA on i2c fix on 0.4.7?


I haven’t seen a new post on sprints or firmware releases in a couple week. The i2c bug is really killing me, is there an ETA on this fix? I am eagerly awaiting 0.4.8 :grinning:


I’m also curious on 0.4.8 and whether the sleep issues will be resolved. Have had to stop development for now.


I’ve checked with the firmware team, and I think they won’t be able to push out the 048 firmware release until at least sometime this next sprint. Sorry about the delay!



okay, is there an ETA on the next sprint?


sure! This sprint wraps up next Tues, and the next one starts after that, that sprint ends Dec 8th.



I tried to go through the forums but what bugs are there in I2C at the moment? Trying to get HTU21D sensor working with the library but both photon and electron keep freezing in random points of the program if I2C is used so if that has something to do with existing bugs I better wait for the fix…


Yes i2c can cause the processor to freeze. It was blamed on pull-up resistors not being present. This will exacerbate the issue. But I do have a properly circuited i2c bus that does freeze-up the processor. It is marked as a “bug” and “in process” on github. So it will be fixed (I trust) on 0.4.8. But it sounds like that will be at the end of next week (at best).


Yes I think there is a problem with i2c devices making the photon lock up at randon.
But I’ve found that SYSTEM_THREAD(ENABLED); does make it more stable.
Without it I tried everything hardware and software to stop it fleezing and the most I got was 4 hours , 2 hours on avarage.
Just added SYSTEM_THREAD(ENABLED); and it`s still running 3 days later.


Please @peter_a, try to use the correct apostrophes in your posts (as pointed out to you before ;-))


@Dave any new on this?


Hi @jerome,

Sorry I don’t have any updates on a new firmware release yet. I know it’s a priority for @mdma and the firmware team to get a release out. Last week was a crazy week for us (we all were in San Francisco for our yearly company meeting), so I would expect more productivity this week than last week. :slight_smile:



Hey guys. Any updates yet?


Yes, 0.4.9 has the fix and should go public on Monday (Jan 25 2016)
You can already test with local toolchain as mentioned in this thread
Particle Firmware Updates: Comments


Excellent job everybody!


@ScruffR, I am not seeing 0.4.9 in the Build Web IDE. Was it released yesterday or did I misunderstand that the release was going to be on the Web IDE? Any information would be great.



@saherr1969, no you didn’t misunderstand what I wrote, but I obviously did misunderstand the “internal” Particle announcment :blush:

This is an official statement


@saherr1969, @tuxie - 0.4.9 is out now!