Error 400 on verify or flash on spark build

I have made an small firmware on Spark build Web IDE but when I try verify I am getting a Error 400.

I have even tried a copy/paste of the first example in the web, attached below and I still get the same error.
The core is working and I can access it via the Android app and via curl command line. It works perfectly.

Is the Web IDE just not functional yet?

// Program to blink an LED connected to pin D0
// of the Spark Core.

// We name pin D0 as led
int led = D0;

// This routine runs only once upon reset
void setup()
// Initialize D0 pin as output
pinMode(led, OUTPUT);

// This routine loops forever
void loop()
digitalWrite(led, HIGH); // Turn ON the LED
delay(1000); // Wait for 1000mS = 1 second
digitalWrite(led, LOW); // Turn OFF the LED
delay(1000); // Wait for 1 second

Error: 400. Please try again later. If the issue persists, please report to

I get the same error after using any of the spark samples. When i click “verify” i get this error. This happens with all the samples… what am i doing wrong? Thanks for your help.

Hey Guys!

Just a quick sanity check can you guys refresh the page or maybe logout / log back in to make sure your session is valid? Sorry if this is a silly suggestion, can you also make sure you’re using a current browser, or if you’re able to reproduce this issue consistently with a particular browser can you report the browser / version, etc?

I was able to compile that code on the web IDE without issue this morning, and checked the logs and haven’t noticed anything unusual just yet, so please let me know if you’re still seeing this issue.


1 Like

thank you… this worked for me. I simply logged out , then went back into build, and “verify” now works for any apps i have tried.

1 Like

Thank you!
Yes, the problem was solved logging out and in.

1 Like