Entire Boron platform for me is destroyed: cannot use Boron with older Device OS versions

I am very frustrated because I have made an investment in Particle and am currently relying upon a Boron for a time-sensitive project to no avail.

  1. I have concluded with high confidence that Particle has destroyed the cellular connection stability sometime after v1.3.1-rc1. I am making another thread about this separate topic.

  2. The Boron platform is useless to me therefore if I can’t downgrade the OS to 1.3.1-rc1.

  3. I have a new Boron that I setup with 2.0.0-rc1. It was connected.

  4. I flashed V1.3.1-rc1 to it. It would never connect. I came back hours latter seeing a blank, dead Boron with no light. I pulled it out of the socket then popped it back in. Back to eternal green flashing. I connected it to my PC with USB. Eternal green flashing.

  5. Then I flashed 2.0.0-rc1 back to it. Viola, it connected.

  6. Then I flashed back 1.3.1-rc1. Eternal green flashing; never connects.

  7. Therefore, I cannot use 1.3.1-rc1. Therefore, given premise #2 above, the entire Particle Boron platform for me is destroyed and utterly useless.

It is upsetting to me that Particle used to, but no longer does, have a product for me where I can connect my sensors reliable to LTE. This is highly frustrating.

Why is this happening?

What is physically different about my Boron unable to connect with 1.3.1-rc1, to my other two out in the field, which have been running 1.3.1-rc1 loyally and perfectly for months, always reconnecting?

Further info:

  1. I flashed tinker and systempart 1 with CLI command line in DFU mode.
  2. I used the same cellular antenna and the same spot for my observations of 2.0.0- connects vs. 1.3.1-rc1 never does
  3. I also tried 1.4.0. Same: never connects.

@Paul_M I assume you are using an LTE Boron in which case when downgrading from DeviceOS 2.x+, you’ll need to go through DeviceOS 1.5.2, otherwise DeviceOS will be unable to communicate with the cellular modem. After downgrading to 1.5.2 (and attempting to connect to the cellular network), earlier releases can also be used.

We’ve updated the release notes on GitHub and Particle Device OS Updates Thread with this breaking change.

Well thank you @avtolstoy for this critical information about the V1.5.2 necessary intermediary from V2.0.0-rc1. We can consider this particular and specific issue resolved then - the V2.0.0-rc-1 failing to reconnect issue is still on the table, but at least with this I should be able to downgrade to V1.3.1-rc1 in the meantime.

@avtolstoy @Paul_M
Could either of you send on step by step details of downgrading through 1.5.2 to a stable 1.3.1-rc1.
I have encountered the same problem with both the LTE and the 2G/3G Borons. I had the 2G/3G connected all last week after receiving it and this morning it was flashing green and does not go any further.
I tried a reset and no change, i tried re-flashing and no change, i tried unlinking it from the app to do a fresh setup and now i can’t even add it to the app.

please help

@paddyronan Did you let 1.5.2 connect to internet/cloud after downgrading from 2.0.0-rc.1?

Hi @Paul_M, @avtolstoy

It would not connect to the cloud when I downgraded. I reset the boron and I can see the following data on screen.
For some reason it was looking for an external SIM so I inserted one in. It may not be active. I can’t seem to reverse back to the internal sim now which is active and was working. I feel like I’m doing circles and getting nowhere. The boron is flashing blue and I am not able to complete setup on the app. I keep getting a message after the device pairs “Setup has encountered an error and cannot continue”
Any suggestions?

This morning i have completed the following steps:

  • particle update

  • particle flash --usb tinker

  • particle identify

  • It defaults to the external SIM so I inserted one even though i registered the Particle SIM and it worked fine for a week


  • Boron stays flashing blue at this point

  • I go to the app and pair the Boron and it pairs

  • I select “NO, DON’T USE IN MESH” and I get the following error after about 15-20 seconds “Setup has encountered an error and cannot continue”

What should I do next?

The Particle setup phone application is garbage and I do not use it. I have received similar issues to you with it.

If you can register the SIM card at http://particle.io/activate, use the -setup-done flag on CLI to make it connect to cloud on boot, and then manually add it to your accounting using particle device add _____ (I think), then that is how I have circumvented the app’s setup failures in the past.

EDIT: My link above is dead. I have no idea where the particle.io web browser SIM activation page went. Email particle.

Hi @Paul_M,

Thank you, I followed your steps not using the Particle App and I am now connected.
One further issue I noticed yesterday was that it was disconnecting at random times from the cloud and I had to do a setup in the app again each time. Hopefully with your fix this does not occur again. I have powered it at 8.11 am today and I will keep the cloud terminal open and check on it randomly throughout the day.
So as I was typing this the Boron became unreachable from the cloud platform but was still pulsing cyan. Pressing reset on the board puts it back into searching for cellular mode flashing green and after a few minutes it connects to the cloud again and pulses cyan. It then becomes unreachable again and a reset puts it back flashing green and it does not recover until about 3 mins after I add the battery.
I am going to do the following:

  1. Leave the battery attached also because as the USB power cable is only giving a max of 900mA

  2. Check my SIM for data

  3. Attach various antennae


1 Like

You are using a 3rd party SIM?
Then you need to set the Particle.keepAlive() to a value acceptable for your provider.
You may start with 30 seconds and then work your way up as far as you get to keep a stable connection.

If you want the device to use the internal SIM but it defaults back to external, you probably once had some code running on that device which ran Cellular.setActiveSim(EXTERNAL_SIM); and since this is a sticky setting you need to (at least once) overwrite it with Cellular.setActiveSim(INTERNAL_SIM);
And for safe measure follow it up with Cellular.clearCredentials().

If you are using a 2G/3G Boron you need a supply that can respond very fast to sudden power demands especially while trying to connect to the cell network - if you can keep the LiPo connected.

Thanks for the reply @ScruffR ,
Is there a command to set the keep alive value in CLI?

Nope, that has to be done by the device itself.

For the sake of finding out which is the best value for your provider, you could have a Particle.function() which you’d call to alter it on the fly.

BTW, you don’t need to reset the device to have it reopen the UDP channel, you just need to have it actively talk to the cloud - e.g. via Particle.publish()

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.