Electrons are booting to white and cannot connect to cloud

I have a few electrons that are having issues (20+ others that are not). They are booting up and can connect to internet but not to the cloud. I uploaded the debugging firmware (tinker-usb-debugging), and the error part of the traceback is as follows:

0000067968 src/system_cloud_internal.cpp:801, int Internet_Test(): TRACE: socketed testSocket=0
0000067968 src/system_cloud_internal.cpp:823, int Internet_Test(): TRACE: Connect Attempt
    67.929 AT send      25 "AT+USOCO=0,\"\",53\r\n"
    68.319 AT read OK    6 "\r\nOK\r\n"
0000068359 src/system_cloud_internal.cpp:825, int Internet_Test(): TRACE: socket_connect()=success
0000068359 src/system_cloud_internal.cpp:834, int Internet_Test(): TRACE: Close
    68.319 AT send      12 "AT+USOCL=0\r\n"
    68.590 AT read OK    6 "\r\nOK\r\n"
0000068630 src/system_task.cpp:205, void handle_cfod(): WARN: Internet available, Cloud not reachable!
0000068630 src/system_task.cpp:101, void manage_network_connection(): WARN: Resetting WLAN due to SPARK_WLAN_RESET

What other debugging steps can I take?

I like this tool:

Submit the whole log at https://support.particle.io and hopefully that will explain what’s going on. If it turns out to have something relevant and non-privacy-sensitive I can let you know and we can copy and paste that section back in this thread to help others in the future.


Thanks for the link. I had already tried the debugging tinker app available through the CLI, but this gave me a slightly different result. All five broken electrons are reporting no SIM card. I’ve tried with several SIM cards (all activated) with the same result. I’ve emailed particle to see if they have any insights…