Electron with Third-party SIM won't connect anymore

Initially, the Electron connected just fine for a full week, regularly coming out of deep sleep mode. Then, after being in deep sleep mode for 3 days straight, it now will no longer connect anymore. The firmware looks something like this:

#include "cellular_hal.h"
STARTUP(cellular_credentials_set("hologram", "", "", NULL));
int tinkerDigitalRead(String pin);
int tinkerDigitalWrite(String command);
int tinkerAnalogRead(String pin);
int tinkerAnalogWrite(String command);
void setup() {
Cellular.on();
Particle.keepAlive(60);

}

void loop() {
  if (millis() - lastConnectSample >= 8000) {
     lastConnectSample = millis();
     Particle.connect();
  }
  if (Particle.connected()) {
      Serial.println("connection established!");
      Particle.publish("particle/device/name");
  	locTime = millis();
      state = PRELOC;
      break;
      }

}
int tinkerDigitalRead(String pin) {

}
int tinkerDigitalWrite(String command) {

}
int tinkerAnalogRead(String pin) {

}
int tinkerAnalogWrite(String command) {

}

I’m quite puzzled by it, especially since it worked before when coming out of deep sleep, which should clear the RAM of the Ublox?

Can you also show your System.sleep() statement with its context?
AFAIK deep sleep does not (always) clear the radio module’s RAM.

Nothing special happens when the device enters deep sleep. I’ll continue to monitor it, but it really is puzzling to me how last week it could go half a day in deep sleep and still connect just fine, but now it will just refuse to do so. Data-limit hasn’t been reached either. I’ve reset the device a couple of times now, and also flashed the firmware a few times again, but it seems that I need to go through the setup process again before it’ll work again.

case SLEEP:
  Serial.println("going to sleep now..."); 
  delay(500);
    System.sleep(SLEEP_MODE_DEEP, 86400);
  break;
    }
}

Also if you wonder, reading this made me believe that deep sleep clears the configuration in the UBLOX RAM. However, as I mentioned it worked before while coming out of Deep sleep, so I don’t think it’s very relevant to my problem.