Electron stopped working?

You’re right that the voltage will drop under load.

In our experiments, the solar panels are permanently connected to Vin. When we start our experiments, it sometimes happens that the solar panel gets a bit of (Myanmar, tropical) light before we get the battery in. That is what causes the brownouts.

Our experiments is about tracking floaters that float down the Irrawaddy river to estimate velocity, but more importantly dispersion. See https://www.instagram.com/researchrolf/ for some impressions.

2 Likes

Thank you for the reports everyone. I think many of you are also familiar with the Bug Bounty post over here because I’ve seen some of you post over there as well. If not, please go take a look and see if there is anything you might be able to contribute. We’re currently still digging into this issue and looking for the culprit. Please keep the reports coming with details, they are very helpful!

@RolfHut which solar panel are you using, and which system firmware version?

I’m on firmware 0.6.0 with all my electrons.

and I’m using these panels, which, given my code, should give me enough power to charge my batteries during the day and run for 2-3 days when not sunny (hardly happens here).

https://www.conrad.nl/nl/Search.html?search=Polykristallijn%20zonnepaneel%200.9%20Wp%206%20V%20-%20110454&sc.queryFromSuggest=true&searchType=SUGGEST&searchSource=SUGGEST_PRODUCT&category=HuistechniekSolar%2Ben%2Bwind

and yes, I’m aware of the bounty hunt post, but am posting here because what I could really need right now is a way to get my bricked units back to life without a JTAG programmer, ie. a workaround to the SWD Fault error in the Blue Norwegian.

I’ll contribute as much as I can to hunting this bug when I’m back in the Netherlands, I’ve got a student going back to Myanmar end of Februari and if she doesn’t have a 100% workaround we might have to switch / cancel her project.

Rolf

Thanks for the info @RolfHut! 6V @ 150mA is pretty weak… definitely not enough to properly power the electron by itself, but good info for a test.

Is there any reason you don’t want to purchase a JTAG tool… they can be super cheap. I recently bought 2 for $5 shipped from this seller on eBay. Tested and working. If you add $2 for faster shipping, you’ll get them in about a week. You can even get these from Amazon Prime for about $6 if you can’t wait.

Simple 3 pin hookup

the reason for not getting a JTAG (now) is that we have one more day of fieldwork here in Myanmar and getting stuff like that here fast is not an option. If I can fix them today, I have two additional floaters for our experiment.

it has been improvising anyway: this is how I made a pull-up…

Understood. When I see things like these tiny JTAG tools for cheap, I buy two… one for my travel case, and one for home. They are like swiss army knives… when you need them they’ll save the day (if you have it with you).

Is that a marshmallow pull up resistor? :smiley:

Here’s how I made some pull ups in the past… I don’t know if they’d survive a floating adventure down a river, but they work well.

Very low power rating I’d assume!

1 Like

Hi @BDub,

the pencil marking resistor is brilliant! Didn’t have pencils, only pens on me… But will add pencils, alligator clamps and jtag programmer to my standard toolkit.

Rolf

1 Like

Oh: and it is not a marshmallow: it is a squeezed wet tissue.

1 Like

Oh no… I have the same problem here! :worried:

I am struggling to build my project, basically an Electron with a few sensors and data sent to ThingSpeak.
I have little time to work on it and a failure on the Electron will stop me for a long time!

In my case, the Electron was working well since a few days, USB powered (UPS protected) and battery plugged in.
This morning I found it with RGB led off and blue led dimly lit. I am pretty sure the battery was well charged and anyway USB power was never turned off. The electron may have been exposed to some sun light in these days (behind a window, winter sun…), temperature between 20°C and 28°C and humidity around 30%.

What is the current recommended solution to this problem? I have a Photon in case it may be useful to reprogram the bootloader, but I’m not so keen to buy a JTAG and do long procedures. Basically I need a solution I can quickly/easily apply. I hope there is one.

I will send a separate email to Support, if that is necessary.
Is any other information required?

Thanks,

       Andrea

As said in an earlier post, if you have another Particle product you could use this

You need to be sure to add code to put the Electron into low power mode when the battery hits 20% or so SOC to keep from the Electron locking up like happened to you.

1 Like

Thanks RWB, I will.

Anyway, as I described earlier, I am pretty sure that the USB power adapter and battery were working fine at the time of the locking up. There must be another reason (too?)!
I can’t believe this issue couldn’t be solved yet… :confused:
Thanks for your help anyway,

       Andrea

The only time I have seen the Electron lock up with the dim blue LED is when the battery goes dead. Maybe your USB power did drop out?

Unfortunately I have no way to check the USB adapter directly. It is a 2A, now powering a Photon, I’ll leave it connected for a few days and see if it gives any trouble.
I’m available to share my circuit (photo) if it may be useful to get some hints on the cause.

Hi @BDub, finally got my STLinks in. Any tips on how to to the actual re-flashing of the firmware? as in, which CLI commands to use?

thanks!

Rolf

Till Brett has got time, this is what I found

to dump out what the current state of your device is.

And here should be your way to resurrect your device
https://docs.particle.io/faq/particle-tools/jtag/photon/

2 Likes

cc @BDub

update, I downloaded the 0.6.1 (3 parts) firmware files and tried to upload them using the ST-LINKV2 using
st-flash write ~/Downloads/system-part1-0.6.1-electron.bin 0x8060000
as command and got:

st-flash 1.3.1
2017-04-20T17:00:46 INFO src/common.c: Loading device parameters…
2017-04-20T17:00:46 INFO src/common.c: Device connected is: F2 device, id 0x201f6411
2017-04-20T17:00:46 INFO src/common.c: SRAM size: 0x20000 bytes (128 KiB), Flash: 0x800000 bytes (8192 KiB) in pages of 131072 bytes
2017-04-20T17:00:46 INFO src/common.c: Attempting to write 52620 (0xcd8c) bytes to stm32 address: 134610944 (0x8060000)
Flash page at addr: 0x08060000 erased
2017-04-20T17:00:46 INFO src/common.c: Finished erasing 1 pages of 131072 (0x20000) bytes
2017-04-20T17:00:46 INFO src/common.c: Starting Flash write for F2/F4/L4
2017-04-20T17:00:46 INFO src/flash_loader.c: Successfully loaded flash loader in sram
enabling 32-bit flash writes
size: 32768
size: 19852
2017-04-20T17:00:47 INFO src/common.c: Starting verification of write complete
2017-04-20T17:00:47 ERROR src/common.c: Verification of flash failed at offset: 0
stlink_fwrite_flash() == -1

as error.

Hmm, yeah I’ve seen that error before on Mac and I usually switch to Windows and use the ST-Link Utility when that happens. Do you have that option?

nope, at least not the next week. Leaving for Vienna in 7 hours where I hope to demo those drifters but from the 3 I have with me, 2 are bricked. Did bring ST-link this time though.

This afternoon while testing my Electron, my USB serial print to screen stopped working. I looked at the device and the 3 colored LED in the center is OFF and the D7 led is dimmly lit. Tried putting it into Safe Mode using the switches but nothing happens, center led remains Off. In the Terminal app on OSX cd /dev and type ls, tty.usbmodem1431 no longer shows up. From reading these posts it sounds like my boot loader has been erased. My Electron had been powered over USB, no battery.
Please advice on how to proceed
Thank you.