Electron power-on connectivity issues with 0.8.0-rcX

Update: this issue has been reproduced by Particle engineers and has been filed as a bug. Thanks, David!

What exactly did you guys figure out was the cause of the problem?

I don’t know that it’s been root caused yet. It was only yesterday that they were able to reproduce the bug. Maybe https://github.com/particle-iot/firmware/issues/1548 will wind up as a 0.8.0 milestone and then we could track it there.

1 Like

Bumping this, as the issue is a blocker in testing/using 0.8.0. I noticed that all the updates to 0.8.0-rcX have focused primarily on small modem tweaks, so I can’t quite tell if there’s traction on resolving this. It’s been three months since the original bug report, so it would be nice to get an update Particle’s current thinking.

@rickkas7, do you know if this is intended for resolution in 0.8.0?

1 Like

@kubark42 could you try this app and let me know what you find? I’m getting good results after disabling charging.

If you don’t get good results, I’d like to see what your logs look like. Start particle serial monitor --follow and then plug in your device after that. You can send them to my email if you don’t want to post here: 08%20PM

#include "Particle.h"

SYSTEM_MODE(SEMI_AUTOMATIC);

SerialLogHandler logHandler(115200, LOG_LEVEL_ALL);

void setup()
{
    PMIC().disableCharging();
    Particle.keepAlive(30); // would recommend 30 seconds with any 3rd party SIM as a default
    Particle.connect();
}
1 Like

Initial tests are good here as well. I simply added PMIC().disableCharging(); at the beginning of my program. Boots and stays online for several minutes.

Interesting! I wonder, have charging parameters changed in 0.8.0? And how would this interact with the system not having a battery at all?

Thanks for figuring this out. I’m pumped about finally being able to access all the coolness of 0.8.0-rcX!

We reworked the PMIC Power Management in 0.8.0 to work better for Device Diagnostics. So it looks like something is causing an issue when the system detects the battery as missing. It seems to be causing AT commands to fail completely, but that’s as much time as I had this weekend to look into it. Disabling Charging is something you could have done and probably should have done before if not using the battery.

I’ll have to make sure it’s in multiple places in the Docs. I’m sure it’s in there in at least one place though. That said, not disabling charging shouldn’t cause the modem to stop responding to AT commands.

I’m thinking the Power Manager might be switching power to the BAT pin forcefully and causing power loss to the modem, in an effort to detect when the battery is disconnected and connected.

2 Likes

I think the only part of the documentation I’ve ever consulted was where it discussed the required powersupply for non-battery operation. I’m fairly confident I didn’t see anything to the effect that I should disable the battery charging. But now I know!

I think this unit is doing fine now. For sure, we see it transmitting data continuously, and the health metrics show up in the Particle cloud. Maybe we can consider this bug has a workaround, and then the scope can be reduced to why the battery charger has an interaction with the AT commands?