Downloading Tracker Edge firmware

Hi,
For the CAN application, after unzipping the downloaded folder ‘tracker-edge-develop’ and clicking ‘Particle: Import Project’, I got the warning ‘Folder path cannot include whitespace!’. Tried the other folder ‘tracker-an017’ and there was no ‘project.properties’ file in the folder.
Do I really need to go through this step since it shows device firmware v13 in console?

Does your user name contain white spaces?
Since the default location for projects resides somewhere under your user’s home directory having a user name with blanks will cause such warnings.

Not exactly sure which step you are referring to but in order to build the Tracker Edge firmware (with your modifications) you need to have the full repository to successfully build the application firmware even when the correct device OS is already installed.

1 Like

Thanks.

You cannot download the Tracker Edge firmware that way, as it will not get the required submodules.

The instructions are here:

https://docs.particle.io/tutorials/asset-tracking/tracker-edge-firmware/#getting-the-tracker-edge-firmware

It was ok, I mean all the LEDs were on, in the afternoon and now when I tried to connect it to USB my Tracker One was absolutely off?
Has to be online? or something with company’s IT update (security) today?

Thank you, Rick.

I have followed that link to download the firmware. Is there any way I can find our if I have got all submodules installed?

Cheers,

Lee

Hi,

I have tried another cable and pressing reset/mode testing but all three status LEDs didn’t turn on.
Yesterday I kept the Tracker One connected to USB when I was going through different setting (console, workbench and my laptop). Later when I tried to power it up again the LEDs gone.
Console showed ‘Device offline’ and cmd - particle setup’ showed ‘No devices detected via USB’.