Desktop IDE (Dev) installs with strange interface, not sure how to use

argon
Tags: #<Tag:0x00007f03947aae88>

#1

I am using a Win10 x64 machine and having trouble installing the Particle Desktop IDE. When I install it, ‘Particle Dev’ opens to the following interface -

What is this? Am I doing something wrong, how to get started deploying code?


#2

Might I suggest you try Particle Workbench, the new desktop IDE, over Dev? It already has more features and is the way to go forward. It support gen3 as well, which Dev won’t do anymore.


#3

Thank you Moors! I will give this a try today, hadn’t learned of this yet.


#4

This thread reminded me to finally delete the old Particle Dev and install the new Particle Workbench today. But actually playing with it will have to wait until I get home from work… Darn it.


#5

Installed VS-Code today, this is a nice tool. Are there any demo applications for the Argon that I can use to get started with? I am having trouble generating a project for my Argon target


#6

You can use the command (Ctrl/Cmd+P) Particle: Create New Project
In the process you’ll be asked for what platform you want to build.
If you later on decide to switch platform, you can us Particle: Configure Workspace for Device


#7

I get the following for ‘Particle: Create New Project

Potentially unhandled rejection [1] Error: EPERM: operation not permitted, open 'C:\Users\justi\.particle\profile.json'
	at Error (native)
	at Object.fs.openSync (fs.js:584:18)
	at Object.fs.writeFileSync (fs.js:1224:33)
	at Object.settings.saveProfileData (C:\Users\justi\AppData\Local\particle\node_modules\particle-cli\settings.js:209:5)
	at C:\Users\justi\AppData\Local\particle\node_modules\particle-cli\dist\app\update-check.js:48:24
	at tryCatchReject (C:\Users\justi\AppData\Local\particle\node_modules\when\lib\makePromise.js:845:30)
	at runContinuation1 (C:\Users\justi\AppData\Local\particle\node_modules\when\lib\makePromise.js:804:4)
	at Fulfilled.when (C:\Users\justi\AppData\Local\particle\node_modules\when\lib\makePromise.js:592:4)
	at Pending.run (C:\Users\justi\AppData\Local\particle\node_modules\when\lib\makePromise.js:483:13)
	at Scheduler._drain (C:\Users\justi\AppData\Local\particle\node_modules\when\lib\Scheduler.js:62:19)
null

- - - -

I am using Win10 Home with Anti-virus disabled, Firewalls off & running as admin. Thoughts?


#8

Can you try close and reopen Workbench?
Before reopening you could try if you even have write permission on that file.


#9

I am an admin with full permissions, and the file permissions are as expected, see below for ref -

I re-opened VS-Code and got the same result. Thoughts?


#10

Yes, but even an admin has to obey the write-protect flag in case its set or another application locks the file against write attempts.

Rename the file and try again.
Try starting Workbench explicitly with admin privs.


#11

This worked great, thank you Scruff! How do you select the target, this was never asked for me. There are also no debug configurations, thoughts?

Thank you for your help here today, this is greatly appreciated :+1:


#12

Via

  • Ctrl+Shift+P Particle: Configure Workspace for Device, or
  • by manually editing the [project].code-workspace file like this
    "settings": {
        "particle.targetDevice": "yourDeviceName",
        "particle.firmwareVersion": "0.8.0-rc.27",  # one of the allowed toolchains (not all versions are supported)
        "particle.targetPlatform": "yourPlatform"   # one of [ photon | p1 | electron | argon | boron | xenon ]
    },

Debugging isn’t yet officially supported (but planned), but you can build debug firmware via
Ctrl+Shift+B Particle: Compile application for debug (local)
And to setup debugging you could follow this