D0, D1 not working with Photon (suspected relay shield problem, was not)

I have a core and relay shield that has been working 9 months, when i received more shields a couple of months, I tried them with a spare core i have and I had no problems energizing all 4 relays.

@timmy6208, I just tried my shield with a 9vdc supply and a Photon and all worked without any problems. With tinker running on Photon, which I got by doing a factory reset, I went to tinker and set D0-D3 as digitalWrite pins. After that I could activate the relays without any problems. Can you control the onboard LED on D7 with Tinker?

yes the onboard LED and relays 3 and 4, not 1 or 2. There is something not right with new photons, just switched to a core and all 4 relays come on. I tried it with a 9vdc supply like you said and the micro usb which I have been using all along.

@timmy6208, what about the D7 LED?

yea no problem i am checking for voltage on D0 and D1

no voltage output on D0 or D1

And you set D0 and D1 as digitalWrite pins in Tinker?

10-4, and D7 when it lights puts out 3.2 vdc. I did try a reflash at first but it had no affect

i meant 3.3 vdc

tried all the analog pins as digital write and they all output 3.3 vdc. I think I got two duds

I pull photon out of the shield and just connected usb power and nothing attacked to the pins. D1- 1.2 vdc D2- 1.2 vdc D3- 3.3 vdc and so on. They have to be duds, even after reflashing?

Hi - I can confirm I have exactly the same problem. Relay Shield v2.0 and Photon. Relays 3 & 4 work, relays 1 & 2 do not. 12VDC power supply to the relay shield.

As timmy6208 I have no output voltage on D0 & D1. 3.25VDC on pins D2 & D3. All pins are set as digitalWrite via Tinker.

ping @BDub

Hey all! Thanks for reporting this issue. I can confirm on my end I’m seeing the same thing, no response from D0, D1 after zero-update. I have seen a few ways to fix this already, and we are investigating what that fastest solution will be for everyone. When we have an official answer, I’ll report back!

3 Likes

Hello everyone, our apologies for this issue. We are investigating this and looking to find out how this has crept into our system. In the meantime, fix is available on the github releases page for 0.4.3 that you can install manually. Please follow the instructions there to update your system firmware to 0.4.3 and D0/D1 pins will become responsive again.

Thank you all for your quick response, I’ll will try this as soon as I can. Thanks again.

1 Like

I just updated your topic title for other users to easier find a solution, if they have similar D0/D1 problems.

1 Like

In the “Advanced Install” section of the page:

http://docs.particle.io/photon/cli/#upgrading-from-the-spark-cli-advanced-install

It says:

To use the local flash and key features you’ll also need to install dfu-util, and openssl.

And the ‘dfu-util’ is linked to a page on sourceforge. However, that link no longer works.

I guess this is due to maintenance

Try any other link on http://sourceforge.net/home.html

Most of them don’t work either.

I got it done using

particle flash YOUR_DEVICE_NAME  system-part1-0.4.3-photon.bin
particle flash YOUR_DEVICE_NAME  system-part2-0.4.3-photon.bin

And, it now works! Woohoo.

Now I am off to figure out how particle.io cloud works. :smile:

Thanks

2 Likes