Certain characters that prevent subscribe() from calling its handler?

Ok, so Im just at the end of several hours of troubleshooting. Found the problem, fixed it, not sure why its a problem, so here goes. Not sure if this is a bug or if there is a reason behind it:

  • I have a RedBear Duo publishing “1A2B3C^Electron_1” as an event name
  • I can receive this publish on my iPhone through a custom iOS app, no problem
  • I could not get Particle.subscribe(“1A2B3C^Electron_1”, subscriptionHandler) to call subscriptionHandler() on my Electron, even though bool success = Particle.subscribe(“1A2B3C^Electron_1”…) returns true (1)

I finally got it to work by removing the “^”. I ended up replacing it with a “~”. I would assume this is a bug, given that it worked between the Duo and iPhone, and the Electron had no problems compiling and subscribing. For some reason it just wouldn’t call subscriptionHandler() with the “^” in the event name.

OR - are there some ASCII characters that will prevent a handler call? I wouldn’t assume so because the docs say:
Cloud events have the following properties: name (1–63 ASCII characters)

Thanks, would love to hear your thoughts.