Cannot interface photon with OLED 128x64

I tried to interface Photon with OLED display.
The pins i have in OLED are
VDD, GND, SDA, SCA, RES, DS, CS.
i took the ssd1302 SPI example and dumped the code. No response on the display.
So, I tried with i2c.
SDA —> D0
SCL ----> D1
RES -----> D4
again no response on the display.
can you help to make this work.

Seeing some actual code, along with images of how you’ve hooked it up might help.

1 Like

Also a link to the display you are using.

2 Likes

This is the display i am refering to. LInk http://www.rhydolabz.com/displays-c-88/096-oled-display-module-spii2c-128x64-7-pin-blue-p-2079.html
Regarding Code. I just took the one which is there in example library available in Particle web dev IDE.
https://github.com/adafruit/Adafruit_SSD1306/blob/master/examples/ssd1306_128x64_i2c/ssd1306_128x64_i2c.ino

If you’ve got the jumpers on the back set to default you need to use 4wire SPI otherwise you should do what’s said on the linked page

Andif you search the forum you’ll find some threads dealing with the SSD1306 display and what to do to get this lib to work.

Thanks.
I will try. Will ask if i couldn’t make it.

I made it through SPI.
Sorry it was my fault … i didn’t read what is stated in that link.

3 Likes

How did you solved it? I mean, I don´t see the capacitor-resistor propposed by ScruffR… I’m having the same issue. Anybody could help me? I think the problem is about the RST pin

@miiguel, OP has decided to go for SPI (in the above image obviously SPI1) after all and hence the I2C demands don’t apply here.

1 Like

My link could help http://sarathiblog.com/particle/particle-photon-interface-oled