Cannot debug with Particle debugger

Now I installed all new also with Visual Studio Code and with Workbench.
When I compiled i always get two errors:

And when I look for problems:


No problems detected…

If I klick debug anyway;

I compile once more and flash, nothing change in launch.json:

And try single step , nothing happens, except:

The stack change the adderess…

Now I spent a lot of time without success.

Without the entire error log it’s hard to tell, but to me this looks rather like a problem trying to flash the app via DFU-util and not like a build error.

Hi

  1. ) I tried to post more pictures to the topic, but the server said a new member can only submit 2 pictures.

  2. ) where can I get the error log?

  3. ) belive me I tried a lot of possibilities… I was playing a long time with the Workbench

  4. ) The problem I posted via mail to your support team, and they told me to make a topic, that thw workbench support team take attention

  5. I also think it is not a problem with the project build

  6. Attached you can find the previous mail

Greetings from Austria

Edi

image001.jpg

(Attachment Memoformat.pdf is missing)

Hi @edi.auratus,
The screen shot seems to complain your device is not in DFU mode. Can you try to put it in DFU mode first manually? To confirm, you should see the LED blinking yellow.

1 Like

I agree with @parhusip here. You don’t state what device you’re working with, but many ship with older firmware that won’t go into DFU mode automatically when flashing from Workbench. Put it into DFU mode manually and update DeviceOS before flashing your firmware.

1 Like

Hi, I had to update the OS in case to flash tinker and also toget connection to the WLAN, the Version is 1.5.2

Lg Edi

image001.jpg