Boron Resetting on digitalWrite

Hi Everyone,

I’m experiencing some issues using a Boron with a custom PCB. I’m using D2 to toggle power to some peripherals and sensors. When I write D2 HIGH, the Particle resets. I suspected there was a problem with the PCB so I tested for short circuits, bad grounds, etc on my board and everything seems to check out. Without toggling D2, everything is good to go.

This is where things get a bit strange and super frustrating… I placed the Boron on a breadboard and pin-by-pin, I connected the boron to the custom board with jumpers. This solved the problem and toggling D2 no longer reset the Boron.

I thought maybe noise was interfering with the EN pin so I tried a 4.7K pull-up resistor. No luck. Also, the problem persists even when cellular is turned off.

I don’t have schematics available at the moment so I apologize for the lack of info.

Any high-order suggestions are certainly appreciated!

Thanks!

I’m shooting in the dark here, so, here goes:
when D2 goes high, do you enable power to some peripherals? if so, could it be that there is not enough power to feed everything?

Thanks for the fast response.

That was my first guess as well. That wouldn’t explain why it worked with the breadboard though, right? Also, this is rev2 of the PCB and rev1 didn’t have the issue. Really banging my head against the wall. Plus periphals are very low power. Again, appreciate the help.

perhaps, unless you were powering the boron in a different way in the breadboard and in the pcb.

It’s dark here… :night_with_stars:

Powered the same way - battery connected to boron on breadboard via onboard Boron JST. Then all pins jumped to custom pcb as if the boron was connected to the pin socket. I’ll try to get some images and info tomorrow morning. Just a shot in the dark!

the exact same battery? :waxing_crescent_moon:

Same battery, yes. (albeit a few minutes later so is it the exact same battery?) . 3.7V 8000mAh LiPo directly to Particle JST. The peripherals that D2 toggle draw well under 10 mA.

1 Like

shot in the dark… Could there be some sort of physical stress related short in the boron headers? Jumper pins are usually thinner than header pins. Could you try lightly inserting the Boron onto the board? Just enough to make contact on all pins, but not all the way in.

so what happened in the end? Don’t keep us in the dark! :))))))))))

1 Like