Boron LTE charging

I’m looking for help with a couple of things regarding battery usage.

My project is essentially a GPS tracker using a Boron LTE and an Adafruit Ultimate GPS featherwing.

  1. The first issue I have is that my Boron shows the below diagnostic information regardless of whether it is connected to a USB port on my computer, a USB wall charger, or nothing. Is there something special I need to do to make it charge? Or am I just drawing more power for my project than a USB can provide?

“charge”: 90.58
“state”: “discharging”

  1. The second potential issue I am having is that I want to use an external LED as a charge indicator as my Boron is in an enclosure. I have tried using the DiagnosticsHelperRK and the instructions in the below topic and the other linked forum posts. My LED never turns on when the device is plugged into USB ports or external power. I originally thought that it was a coding issue, but now I am thinking that it is probably just because of the above discharging problem, but I thought I would include it here in case anyone had any other thoughts.
    Boron Battery Connected

here is a snippet of code from my loop where I am checking whether the battery is charging
int chg = DiagnosticsHelper::getValue(DIAG_ID_SYSTEM_BATTERY_CHARGE);
if(chg == 0){ //red is solid while lipo is charging

The default Li-Po charge termination is ~4.11 V (from memory).
That’s ~ 85% State of Charge.
I assume the Li-po voltage is higher than 4.11V right now…so “discharging” would be the expected behavior.

You can change this to charge up to 4.2V if you wish.
But the Boron should start charging after your Li-Po is discharged below what it considers “full” based on the PMIC settings.

It is now at 84.8% and 1.99V and it still says discharging. I am using the below code to check the battery voltage.

    float measuredvbat = bat_read();

I hope not…Can you measure the Li-Po voltage with a multi-meter ?

You can use getVCell() and getSoC(), see the DOCS:

Using getVCell(), it is now reporting 3.95V and 83% battery.

I still have been unable to get my battery to charge while connected to the boron. I removed it and connected it to an Adafruit Feather M0 I have and it charged up to 4.2V.
Do I have to enable charge mode, or set power source priority somehow?

@crecine, you don’t have to do anything for a Boron to re-charge it’s li-po, as long as you haven’t previously changed the relevant PMIC settings.

I haven’t tested a Boron w/ factory PMIC settings to know what voltage the charging normally starts.
It may be close to the 3.95V (or lower), IDK. But I would think that you should have seen it recharging by then.

I haven’t changed any PMIC settings.
Today when I was testing with the battery and usb connected, it said “charged” and “host USB” instead of “discharging” and “battery”. The battery was at 4.11v and 100%, so maybe the problem is fixed? I will update this once the battery has discharged and I try to recharge it again.

Any luck with the charging state?
I have a Boron I’m trying to deploy for testing, but the charge indicator is playing hide and seek. Seen briefly a few days ago, now nothing.
My supplied Particle LiPo measures 3.87v (no load) and I cannot get the charge light to come on. Tried charging via USB connector and also thru Vusb. Nothing.
Surely I don’t have to play with the PMIC settings?

I haven’t done anything since my last post. I had to submit my project, so I haven’t had access to it since then. As I said in my last post, it seemed to be working when I submitted it.
You could try charging the battery separately and re-flashing your code, which are the only two things I tried before it seemed to start working.
Or maybe someone else knows what to do to help.
Good luck!