BMP085 and Spark Core

I tried different libraries posted in this forum for BMP085 but with nothing seems to be working. I am using Sparkfun BMP085 Breakout Board. Could someone help me to get it working. I am sure I am doing something wrong, could someone help me with circuit diagram and code. I am a beginner in this.

Thanks in advance!


Did you add 4.7k ohm pull up resistors to the I2C lines (D0, D1) ?

@BDub, the BMP085 Breakup Board has 4.7K pull up resistors built in, am I correct?

I tried address 0x77 and 0xEE, but not working.

Sparkfun says that the i2c pullups are jumper selectable on their newer board. Can you check for a jumper or solder blob on the three parts of SJ1?

I am using this one SEN-0969 ( and I can see solder blob.

You should be using address 0x77 just to make sure.

Are you using this library?

If so you may want to modify the setup()

void setup() {
  Serial.begin(9600); // start Core with Serial terminal Closed, then open serial terminal
  while(!Serial.available()) SPARK_WLAN_Loop(); // wait for user to press ENTER in serial terminal

  if (!bmp.begin()) {
    Serial.println("Could not find a valid BMP085 sensor, check wiring!");
    while(1) SPARK_WLAN_Loop(); // Die, with the possibility of reincarnation

(I just updated the Gist with this better code)

This pinout?

// SPARK CORE PINOUT ---------------------------------
// Connect VCC of the BMP085 sensor to 3.3* (NOT Vin!)
// Connect GND to GND
// Connect SCL to i2c clock - on Spark Core this is D1
// Connect SDA to i2c data - on Spark Core this is D0
// EOC is not used, it signifies an end of conversion
// XCLR is a reset pin, also not used here

Are you seeing this error?

"Could not find a valid BMP085 sensor, check wiring!"

@BDub, Let me try from the very beginning and get back here.

I tried from the beginning and still not working, one thing I found is that Spark Core hangs at bmp.begin(), I am trying another BMP085 and will update here.

Tried another BMP085 and is working. What is confusing is that the older one works well with Arduino and not with Spark Core, its very strange. Anyway I got it working with another one.

Thanks @BDub and @bko for the help.

1 Like