Blowing up a non-5v tolerant Photon pin

In trying to get analogRead to work, I may have accidentally touched A4 or A5 to more than 3.3 volts.

Can anyone tell me the symptoms if this happens? Possible answers:

  1. You probably didn’t blow it up. You have to really connect a high voltage to hurt these pins, and for a long time.
  2. The pin in question will no longer function as an analog pin.
  3. The pin in question will no longer function as anything.
  4. All analog pins will no longer function.
  5. The internal A to D will be blown up but all the pure digital pins plus the digital functionality of the analog pins will work.
  6. Nothing whatsoever will work in the Photon.

I am using a Shield/Shield. (Yes, the shield/shield does not protect for analog pins.) The base functionality of the Photon still works. I have not been able to get analogRead to work at all. I tried it using the “pinMode(TEMPERATURE_PIN, INPUT);” statement and then without the statement; no difference.

The ‘int’ that comes back is either 0 or 1 for “low voltages” like less than one volt, OR for 1.5 v or 3.3v it reads full scale 4095.

Firmware version is 0.4.9.

These are the only include files:

#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#include <stdarg.h>
#include "application.h"


I’d most likely go for 2) with a possibility for 1) if your voltage was not too much over 3.3V and only short.
But if were actually “excessively” high and/or long you might get anything up to 6).

To test things take the device out of the shield, put it in a breadboard with only a voltage divider between 3V3 and GND, write a simple sketch that checks all A-pins one-by-one (each for a few sec to give you time testing) with Serial.println(analogRead(A0+i)); (i being 0…7) and then use a jumper wire to test pin by pin.

Where do you get your test signal from?
Your behaviour might also come from not having common ground for Photon and test signal.

Turns out that in the shield/shield, NOT all A pins can perform an analogRead. Only A0 and A1. This differs from the Photon operating naked and NOT plugged into a shield/shield.

Although I connected A4 accidentally to 6.5 volts, the “protect the Photon” capability of the shield/shield worked properly. Thank you to the designers!

The signal comes from a temperature sensor on a sensor board we laid out. 3.3v feeds from the Photon to the sensor as does ground. The output of the sensor feeds back to the Photon ADC input. Placing my finger on the sensor makes the readout nicely rise:
Raw Photon ADC integer: 909, C: tempC: 23.253, tempF: 73.855 , time from last event: 3 seconds

However, I still don’t know the symptoms of a blown Photon pin.

I guess you don’t really want to either :wink:

But you can virtually have all sorts of symptoms, permanent HIGH or LOW or high-z.
You can loose ADC capability only too.
Usually only one pin blows and the others don’t or you damage a whole port or multiple or …

All depends what you did wrong and in what mode and state the pin was when it happened.

So, you see nothing fix tho’