ATOMIC_BLOCK() not compiling



OK so I upgraded to 0.4.9, but the IDE and CLI compilers refuse to allow Atomic_Block() to be compiled.

Do I need a different header file or something ???, OR are these compilers not actually compiling for 0.4.9 :open_mouth:

All previous comments have suggested that Dev and CLI compilers automatically compile for the latest release…

Ground to a halt trying 0.4.9 now …




OK - so now I can see that even web build does not list 0.4.9 yet - even though it was released earlier today ???.

Can someone turn this on please …




The firmware was released on GitHub but not yet pushed to the cloud systems, near as I can tell. That means: no OTA update to 0.4.9 (with the public cloud), and no compiling in the cloud for 0.4.9, until they get everything up and running. @mdma had mentioned in another thread that they will post up a notice (presumably in the forum) when that is complete.

See here: Particle Firmware Updates: Comments


0.4.9 is now available via the :cloud: :smile: