Arm-none-eabi-g++: nano.specs: No such file or directory

Just tried to build new (July 2nd) bug fix source:

It made it most of the way through but finally gave this error:

arm-none-eabi-g++: nano.specs: No such file or directory
mingw32-make: *** [core-firmware.elf] Error 1

I have been able to build past source no problem.

I searched for a file called nano.specs in my file system, and there are several of them in the arm-none-eabi/lib folders.

The new makefile has a couple of extra lines but apparently my toolchain doesn’t know what to do with them:

LDFLAGS += --specs=nano.specs -lc -lnosys
LDFLAGS += -u _printf_float

I am using this compiler (running on XP):

Not sure about the compiler link that you mentioned above.

Try this link instead and make sure the %PATH% env. variable is updated:

1 Like

Thanks Satishgn. You’ve been a tremendous help in the connectivity issues I’ve been having, and with this problem as well.

Turns out I have several different arm toolchains scattered in my filesystem. Installing the one you mentioned did the trick as long as I run it from the command window that is provided with it in the install.

1 Like