Argon Setup Failure


#1

Just got (3) Argons and (6) Xenons. I have attempted to set up two of the Argons and both fail to connect to the internet. Using the Android mobile app to set up, after providing wifi credentials it hangs on the “Connecting to the Internet via Wi-Fi” step. The led blinks green for about 10 seconds and then fast blibks green for about 15 seconds. The led then gives a single quick white flash and starts the green blinking cycle over again. This cycle happens indefinitely until I force the Argon to Listen mode or do a factory reset.

I was forced to perform a 2-part update to the Argon as part of the setup when it first started.

Anyone having the same/similar experience and have a solution?

Have to say I’m kinda disappointed in the experience so far.


#2

Do you have an Arris Broadband routers? There’s a thread on here about Arris routers having issues with IPv6. If your router does have IPv6, can you disable it?


#3

No Arris. Using a Ubiquiti USG3.


#4

Still check the wifi setting if you can, and disable IPv6. Also, please make sure you have a 2.4 ghz network. Mine was a linksys dual band but it seems like ESP32 does not like that, so I had to create a dedicated 2.4 network and setup network mode to G and channel to 4 (randomly pick a number rather than the auto option)
Then I used my laptop as a hotspot and created a network and use that one to connect my argon to it and it worked.

Hope this help


#5

So, on a whim I broke out my ATT LTE hotspot and tried to connect using that and it was able to complete the setup process. So it would appear to be something with the Unifi ecosystem. I tried creating an explicit 2.5 Ghz wlan just for these devices, I ensured that IPv6 was disabled, and I made sure there were no special characters in the SSID or password but it still would not connect. In the Unifi SDN I can see the device connecting to the Wifi SSID but it will not pull an IP address. This is unfortunate since more than half of my prod environment uses Ubiquiti products.


#6

Please see


#7

@MrHofflich - Are you saying that you disabled IPv6 from your WAN connection or your WLAN connection?


#8

After checking with Rick from Particle Support, he hopes this will be resolved with the following:


#9

WLAN, I would say. It was in the change adaptor settings and chose the Wireless Networking.


#10

Trying to set up my first Argon of a couple. Android App downloaded Part 1 then Part 2 of the software then stalled with the Particle Star rotating in the middle of the screen. I have patiently waited for 20 minutes and no change.


#11

I finally used the top left X to exit the install and started the install over. Program said the Argon was found.


#12

I have exactely the same issue. Not connecting to the cloud and continuesly blinking green.
Hopefully a solution will be found. I see in the page “Particle Mesh Known Issues and Fixes” that the issue has been reported (point 4 of the Outstanding issues)


#13

Good News!!!

The latest device os (0.80.0-rc.26) DOES resolve the issue with Argon’s not being able to connect to your selected WLAN during setup. I have only tested the device os install for WLAN resolution so I can’t speak to any of the other fixes but at least I can play with the device now.

Happy Meshing!

-Sergio