Argon can't connect through app


#10

In my case, the app suddenly goes back to the initial screen (empty) once Argon starts looking for WiFi networks.


#11

Similar issue: I was able to pair the argon and my Google Pixel. Argon updated firmware OK. I gave it the WiFi credentials. My phone reported connection to the internet, but then the argon sent into a connection cycle alternating slow green blinking and fast green blinking interspersed with a flash of cyan. I can not now pair to the argon. Reset and power off did not work. It is now a blinking small brick.


#12

press reset and mode together. release reset while holding mode for ~10 seconds. The light will go through a progression of colors which escapes me at the moment. After about 10 seconds the device will reset to factory and you can try again.

This is documented here: How to do a factory reset


#13

Thank you! including the rest link. It is reset and I can start again. The soothing blue blinking light is back!


#14

That link is almost five years old and refers to the first generation of Particle devices, certainly not Mesh.
The docs mention the following: https://docs.particle.io/tutorials/device-os/led/xenon/#factory-reset


#15

I received my 10 Xenons and 3 Argons today and wanted to create a mesh network to evaluate these new products.

Now I have tried for about one hour to register the first Argon and I did not manage to get it registered:

While connected to my iOS Particle App via BT, it requires the SSID and password.

When I enter the password (format “xxxxxxxxxx,99”) it says “Incorrect password”!

:disappointed_relieved:


[Updated 12/20] Particle Mesh Known Issues and Fixes
#16

Can’t wait to see how the 9 Xenons work for you. I have 5 xenonx on test now.

Can you change your password so the ”, ” is not in there? I’m assuming that’s the issue.

You could also try another device for the setup to see if it also throws the password error message. My setup went well on an iPad and there are issues with Samsung phones so avid that for now.


#17

Do you have special characters in your password?


#18

As you can see, yes, a comma is used to make the pw more secure.
This is used since 5 years now with many devices and without any issues.

Do you mean that the Mesh devices don’t accept that?

It is quite troublesome to change the name now because all devices used must also be changed…

:weary:


#19

There is a fix to allow special characters but not released yet.


#20

Ok, that’s great to hear @kennethlimcp!
I will try them on another network meanwhile.
Thanks for this tip!


#21

Just to be sure that I am not communicating something vague :slight_smile: --> https://github.com/particle-iot/firmware/pull/1604


#22

@robie1373 Does your WiFi password contain any of these characters: ,, ", \? As mentioned by @kennethlimcp, there’s a known issue with Argons being unable to connect to a WiFi network if its SSID or password contains certain characters. If that’s not the case, would it be possible for you to flash a firmware binary that has the debug logging enabled to your device, then capture the logs via the hardware serial?


#23

The device reset worked. I am still stuck on the argon connection to the particle cloud. It sounds like others may be having the same problem. It may just be a newby problem. I can pair the phone and Argon, I can add my local network ID and password. I get a “connected” message on the phone to say the argon has a network connection. Then however the Argon hangs on getting the cloud link. The phone locks on the connection screen with the compass rose spinning for half an hour. The Argon blinks green fast and then green slow I assume while it is trying to connect. Is there perhaps a WEP security issue? While the phone says “connected” maybe it can’t reach to the cloud.I have tied both connecting the argon as WiFi and as Mesh. I now am assuming mesh is a wrong choice. I should note as well that I have no special characters in my password for my LAN but my cloud account has a “)”. I will try changing tonight when I get back to the Argon Board.


#24

Today I registered 3 Argons on a wifi network with a different password, containing only alphabetic characters and it worked very well!

Thanks for the tip and looking forward to being able to connect to networks with special characters.

Also the registration of the 10 Xenons worked very well via BT. Congratulations to the Particle team for their good job in creating this process!!!

On the other hand, I am NOT impressed with the maximum distance between nodes of a mesh network!
It was my hope to solve the connectivity issues I am experiencing with my network of 10 Photons…

So, I tried out many indoor situations today with my network of one Argon and 10 Xenons and one wall is enough to break the connection! But I guess I should post this worry in another thread…

:thinking:


#25

Believe I’m having the same issue.
I’m trying to connect my first Argon using the mobile app. I get the blinking green then fast blinking green and it cycles that way indefinitely. No special characters in my SSID or pwd. Tried a few factory resets but no dice.

I was really looking forward to trying these out as replacements for the photons in my project but I’ve quickly lost confidence.


#26

I got an Argon to set up with no issues. Got excited!

I’m having a similar issue with Xenon - the message after “congrats…” is a “Something went wrong with Bluetooth. Please restart the set up process and try again.”

I’ve started over several times, restarted my iPhone (iOS 12.1). I’ve turned off and on Bluetooth.

I tried the factory reset - it blinked yellow for a couple minutes. How long should it go? It would not respond to the left button. I clicked the right button, it stopped flashing yellow, started blinking blue. Tried again, same error.


#27

@sergey my wifi password is alphanum only. I will work on getting some logs when I get back home. One of the reasons I like particle devices is I can (generally) hack without a faffing about with a bunch of janky usb serial BS. /oldmanrant.


#28

Nope, in this case it’s a xenon, and just trying to add the device before even adding it to the argon gateway


#29

There is definitely an issue with the iPhone or ios or split-band wifi networks. I tried my new Argon several times with the same results as noted above - it gets all the way to entering my credentials, then an error pops up that the bluetooth is lost, and the Argon goes to rapid flashing green. I need to go to factory reset and start over (with the same results every time).

However, after turning off the phone wifi and using its hotspot instead of my home wifi, it connects fine.

I have a TP-Link Deco M5, which creates a 2.4/5GHz network. My SSID is all alphanumeric, and my password is like Abcdefghi1. Any other things to try to get it to join my home network?