After SoftAP config, photon breaths green but IS CONNECTED to particle cloud

I have a product that runs fine. I recently changed the code to only send data every 6 minutes, rather than every 15 seconds. After the device wifi is setup using softap, the device blinks as you would expect then ends up breathing green. Everything I read suggests that means its connected to wifi but not particle cloud. Except it is connected to particle cloud and functioning normally. If you power cycle the device it breaths blue. I can’t really figure out why?

looks like your code is blocking main loop but is hard to say without seeing your code .
Try to avoid long Delay() (use millis() instead ) and use SYSTEM_THREAD(ENABLED);

Yeah, thats what all standard answers are but the code isn’t blocking in loop and the delay is 100. Same result with system thread enabled or not. And again, it is working, is connected to the cloud. Just breathing green

This post was flagged by the community and is temporarily hidden.

Interestingly when i go back to an older version of our app, I get the breathing green after softap changes as well. I think when I pushed the new code it updated the device to 2.2.0. My assumption is there was some change in OS code after a disconnect from SoftAP. I worked around the problem by putting a callback from softap disconnect setting a reboot flag. Then in the main loop I reboot the device if the flag is set. Strange but it gets me back to breathing blue and new configuration.