Adafruit GPS Photon problem


#41

Hey, just thought I would comment on this topic regarding the signal fix time.

I have been playing around with both the Adafruit GPS and a $10 ublox NEO-6M I picked up on ebay. I too found fix times to be unpredictable and lengthy. Yesterday my active antenna arrived and I cannot get over the difference it makes. Before I needed the GPS at the window and a fix still took a 5 minutes best case on a cold restart (hot restart fix time was always pretty decent), however with an active antenna it picks up numerous satellites quite quickly in the the middle of my room. The downside is the cable is a little long, but I will try to shorten it, definitely worth the $3.

http://www.ebay.ca/itm/New-28dB-Gain-1575-42MHz-RP-SMA-Male-GPS-Antenna-Aerial-Stronger-Singal/251757787307?_trksid=p2047675.c100009.m1982&_trkparms=aid%3D222007%26algo%3DSIC.MBE%26ao%3D1%26asc%3D20140620091411%26meid%3D22f1ef72293946728f5e5a5512160494%26pid%3D100009%26rk%3D4%26rkt%3D10%26sd%3D121515720074

Just some food for thought


#42

@Dave, I tried connecting adfruit GPS https://www.adafruit.com/products/746
with my electron which i had recently received. But no luck. The same GPS locks with in two minutes and works perfectly with arduino uno r3 (used parse.ino from adfruit library) inside home!. Connections i made for Electron
1.Tx of Gps to Rx of electron,
2.Rx of Gps to Tx of electron
3.Gnd of electron to Gnd of Gps
4.3V3 of electron to Vin of Gps
and used sketch
ASSETTRACKER 0.0.2
I did not get fix.

I tried connecting GPS to arduino uno r3 only for the power up and connected Rx/Tx to electron, i got GPS fix in two minutes!.
My question - Is adfruit GPS works well only with your assettracker sheild? or do i need to do some changes in powering GPS?

Please let me know your suggestions.

Thanks,
Jay


#43

Hi Jay,

The enable pin should be pulled (high active… I think?) by default, but it might not hurt to do that explicitly. Also make sure you give it really clean power, powering it directly from the electron might have some interference. You might also need to not put the GPS on the same breadboard, etc. GPS modules are extremely sensitive to noise / power conditions / etc.

Also make sure you have a clear view of the sky / horizon, or use a nice external antenna, and your antenna should be flat, that should help!

Thanks,
David


#44

Anyone has reached a solution ? I got with the same issue.

I have a cheap GPS module (GY-GPS6MV2) with the NEO 6M module, and I was running with some issues related to the fix time, so yesterday I received the Adafruit ultimate GPS, but the fix time is much longer than the cheap module.

I added a electrolitic cap (100uF) between VIN and GND and I connected VIN to photon’s 5v pin. After a long time, I can get a first fix, but my test are : put the modules on the balcony, after a fix on both, put them back both modules into the room (near to the window), and the adafruit module has lost the signal (I dont know if is the proper term), but the NEO 6M dont; I put the NEO on a room with no clear access to the windows and the NEO lost the signal. After that I put both modules back to the balcony but after almos half an hour the adafruit module is still in fix phase, but the NEO 6M get pretty much quicker fix.

Thanks if you have any advice.


#45

Hi @maleficarum

When I see your picture with the breadboard, I can see almost all the wires for the GPS go directly over the antenna region of the Photon at the end opposite the USB connector. I would definitely redo the wiring to avoid having any wires go near the WiFi antenna and preferably move the GPS to the non-antenna end of the Photon.

If you still can’t get good reception, then I think you need an active GPS antenna.


#46

Ok, Ill try that … thanks.


#47

I’m trying to use the Featherwing GPS module with an Electron and I can’t seem to get a connection to my Electron through the serial monitor on my computer. I’ve tried a bunch of the libraries but can’t get it to work and am wondering how you guys are doing it? I’ve got the GPS module hooked up to an UNO so I know the problem isn’t with it at least.


#48

Can you post your connections and code? I’ve noticed that in certain situations, you can’t acquire a fixed location as quick as you can expect (even with other GPS modules). So, you can try to hook up antenna and try outdoors.