0.6.0.rc1 - USB Serial - only seeing one but expect two

@avtolstoy, @apt,

Updated to the latest Particle USB CDC Windows Drivers, version

Device now manager shows two serial ports as expected:

  • Photon Serial (COM153)
  • Photon USBSerial1 (COM154)

Correct output to the two serial ports as expected.

Case closed with thanks!



Would like to mark this ticket as [SOLVED} but I can’t access the title title any more. Are you able to do this for me???

We have a :ballot_box_with_check: Solution icon at the bottom of each post (might be hidden behind the ellipsis)
If you hit that on the post that solved the issue, the thread will be marked solved


AHA! Obvious now that you have pointed it out!

1 Like

Thanks for your more successful research, @UMD. I gave up, perhaps too early.

I have to say, I found the initial installation and configuration of node.js, npm, sundry random utilities (zadig) and particle a complete PITA! It took a slow and frustrating install/de-install/install cycle to get it basically working, and I’ve been scared to touch anything since. This introduction via spaghetti code installation gave me a very poor opinion of the engineering behind the product.

My opinion of the device itself has improved (although I’m banging my head against a steep learning curve and tight deadline), but @Particle would do themselves no end of favours if they spent a little time removing bad (well-intentioned, but out-of-date and misleading) information about the PC software installation process from the forums and actually provided an up-to-date set of software and accurate instructions in their reference section… I guess this isn’t the place for this rant, however, so sorry, mate!

On the plus side, I will use the link to the new drivers you found, and try them out. Many thanks!



Stick with it - just think if you had to do all this stuff yourself from scratch!

Fundamentally, it is complicated.

The Particle community is great and there are very few problems that can’t be overcome.

Particle has come a long way and we can all see the continuing improvements. Enjoy!


@UMD, @Scruffr,

Yep … I will. I have to, as I designed a PCB around the device, before getting one! :wink:

I thought it was a great concept at a very good price, and hoped that the higher level of integration (vs an Arduino or Pi with separate shield/hat 3G modem, for example) would make my life easier.

I have installed the new driver (why isn’t it packaged with the current Windows CLI installer - this ‘new’ driver version is almost a year old!? The installer put in 5.2). Retried my test firmware, and - YAY - have two serial ports (COM8/9 by default). All fixed, thanks, gents.

Note: Not sure if this affected you, but the driver installation (I had to do it twice) only completed successfully (ie. with W7 popping up the installing drivers message in the corner) if I had the Electron plugged in to the USB. Otherwise, it apparently installed, but did not update the Electron device driver, even after a reboot and plugging in the Electron - still showed as 5.2 at the driver level.

Just adding this for information, anyway. May save someone a puzzlement.


1 Like