Using Particle Mesh Devices with the OpenThread Border Router

The topology monitor seems to be only for a mesh made up of specific nRF52840 Preview Development Kits. The sniffer, which uses the USB dongle, only works on Linux.

1 Like

@rocksetta, at some point, Particle will need to expose some of the mesh management and measurement Nordic API to the user. This would be needed, for example, to set a repeater/non-repeater role. I have not idea when Particle might do this however.

2 Likes

Nordic has a ton of Android Apps at

any idea which would be applicable with this dongle? I think perhaps the connect for mobile and the nrf Mesh

I just ordered a Nordic USB dongle which I will play with over Xmas.

3 Likes

The Xbee3 radios can communicate via Thread also so maybe there are tools or info sniffing tools for that network that could also be helpful with what your trying to do here.

1 Like

Found this video about the main types of mesh networks.

@rwb any idea if the Xbee3 have a usb version of their board.

.

.

Found this XBee Explorer USB Dongle Does not mention OpenThread so not sure if it is relevant.

Another nice tutorial https://medium.com/@jaredwolff/how-to-get-started-with-openthread-b137bc6062f9

@rocksetta I could have swore I saw Thread as a network topology choice in their advertising but now I can’t find much on it.

The links for Thread on their website has been removed for some reason.

They do have a Thread ready RF module here: https://www.digi.com/products/xbee-rf-solutions/2-4-ghz-modules/xbee-zigbee

Seems like they are moving away from Thread for some reason.

1 Like

I have been looking at the OpenThread Github and I am surprised how un-userfriendly it is. Most github README.md files have easy to understand installation instructions, and a bit about the API or at least a link to some kind of an easy to understand API. They have tutorials but I can’t find much on an API.

The problem with using an open source protocol is if the protocol changes you have to change with it, (I was making tutorials on deepLearning.js when it got absorbed by Google and became tensorflowjs, that one change made my tutorials obsolete, without a ton of work to get caught up.) Digi is in the nice situation of having their own protocol and a method to work with Thread protocol.

Would be very cool to make a video like the above one with Particle products talking to Digi own protocol and Thread products.

2 Likes

Here is a list of all the openthread platforms from their github: and the information here

cc1352
cc2538
cc2650
cc2652
da15000
efr32
emsk
gp712
kw41z
nrf52840
posix
samr21

I wonder how many cell phone apps have access to OpenThread and how many of the above platforms have USB dongles. Theoretically eventually all these platforms should be able to communicate.

I think along with @peekay123, who got the Nordic dongle, I need an early xmas present of a few dongles to try.

searching on the above information got this nice information page and long range part 2

@rocksetta, no cell phone has access to OpenThread as none have hardware that supports 802.15.4 used by OpenThread. Thus the need for the dongle and a PC.

As far as I know the PC must be a linux (or Mac). I believe the border router uses the cell phone to connect the hardware much like the particle system does.

When getting sensors working for the Photon I typically purchase 3 of the same type of sensor (say an accelerometer) but from different companies and I only tend to get one fully working, not sure if I give up on the others or if the other sensors don’t actually work with the Photon. So now I am looking to purchase 5 USB dongles to see what I can get going on a Linux box or the RPI3.

It looks like an openThread network can handle lots of border routers so I think I will get:

2 x $10 NRF 52840 Nordic USB dongles, so I can understand whatever @peekay123 gets working.

1 x $16 Seedstudio nRF52840 MDK Dongle

1 x $25 XBee Explorer USB Dongle

Can anyone make a suggestion for one more dev kit to try or if I am making any mistakes with the above purchases. I have found a few USB production ready OpenThread sticks but they are getting expensive.

kirale $49

em358 $??

ETRX358 USB Stick (not recommended for new designs ?? ) $??

Firefly about $53 USD if the Euro is really doing badly

The more I research the more I like the nordic usb dongle. Anyone know of any others?

Found some nice OpenThread tutorials…

https://codelabs.developers.google.com/codelabs/openthread-hardware/index.html?index=..%2F..index#0
https://codelabs.developers.google.com/codelabs/openthread-simulation-posix/index.html?index=..%2F..index#0
https://codelabs.developers.google.com/codelabs/openthread-simulation/index.html?index=..%2F..index#0

4 Likes

I posted this on the Google Groups Openthread-users

So I ordered:

3 x NRF 52840 Nordic USB dongles

3 x Seedstudio nRF52840 MDK Dongle

3 x Fanstel USB840F

I think it might be a big waste of money.

As mentioned here my Fanstel USB Dongles arrived, the other 2 types are on backorder.

I seem to be able to activate the OpenThread Border Router Docker on my Ubuntu laptop, but I am really confused about how to update software on the Dongles. I think it should be fairly easy with the USB connection and all, but finding simple working examples is not very easy. What makes things even more confusing is the terminology. Some pages talk about bluetooth 5, others Thread and others OpenThread. Most examples are for Dev boards and not for the Dongles.

Absolutely no information came with the Fanstel Dongles and I don’t even see a button of any kind on the USB stick. (There is however a Phillips screw that is just begging to be unscrewed.)

If anyone has worked with these or has any suggestions for sending programs to them I am all ears.
I know the firmware image is here and JLINK is supposed to be useful but I don’t even know how to install JLINK

I just like making bash files of all the installation commands and then never having to think about that stuff ever again.

@peekay123 did you get your Nordic Dongles yet?

1 Like

I come from a hardware hacking background before I became a networker… I see that phillips screw head, and wonder if there are pushbuttons inside the case, and maybe a debug header… and you have three of them (you could open one,and still have two). :slight_smile:

2 Likes

@rocksetta, I only ordered the “sniffing” dongle which, in theory, should be able to sniff the OpenThread traffic only.

I personally would not have purchased anything NOT Nordic for testing only because they are so poorly supported. One thing I did notice re the Fanstel:

Bootloader is preloaded in Bluetooth module. SoftDevice and application can be loaded by Over-The-Air firmware update. A TAG connect cable TC2050-IDC-NL-050-ALL can be used to connect to nRF52DK to load bootloader and other codes.

You would most likely need the Nordic USB dongle to program the Fanstel dongles OTA though I have not looked into the documentation to know how. I believe Fanstel used “Thread” to mean OpenThread. Take a look at the Nordic dongle information:

https://www.nordicsemi.com/DocLib/Content/User_Guides/nrf52840_dongle/latest/UG/nrf52840_Dongle/intro

I believe the dongle allows you to connect to a mesh of nRF52840 DK dev kits and use their tools to OTA, get mesh information, etc.

2 Likes

You might be right, that would explain some of my issues. Heres what I have so far:

I can’t mount the USB Dongle on Linux using a typical USB mount command like

sudo mkdir /mnt/mydongle

sudo mount /dev/ttyACM0 /mnt/myudongle

Gives a block error saying it can’t be found.

I have installed JLINK
on Ubuntu by using these steps:

sudo apt install gdebi-core

sudo gdebi JLink_Linux_x86_64.deb

I think JLINK should be enough to install the NCP image onto the USB Dongle but the instructions seem to think you need the Nordic nrf command line tools which have been deprecated. (That is a bit concerning that NordicSemiconductors has deprecated there NRF tools!)

Strangely they do seem active on a NodeJS github called pc-nrfjprog-js that mimics the nrf tools.

I am going to research if JLINK is enough to transfer the Image to the Dongle, and perhaps see if I can use node to transfer the hex file to the Dongle.

LOOKS LIKE WINDOWS TO THE RESCUE FOR LINUX. How many times do you get to say that :laughing:

I seem to be able to install nrf tools onto windows.

Just found this tutorial

Now installing windows https://www.nordicsemi.com/Software-and-Tools/Development-Tools/nRF-Connect-for-desktop

OK. Strangely easy. Not even sure what I have done, but dropped my NCP .hex file into the USB Dongle. Will now have to test it with the border router.

1 Like

So after much head banging against the computer I think the latest problem is that the Fanstel USB Dongles use a secure DFU bootloader instead of just a regular DFU bootloader, which means everything needs to be signed to be installed.

What I thought was successful on the windows machine eventually was exactly the same on Ubuntu. nrf-Connect for desktop can find the USB Dongle and can find the .hex file to load, but will not allow activation of the write ability to move the hex file to the Dongle. I think the problem is the secure part. I have to somehow sign both the bootloader and the application.

I did have a few small successes:

I got the docker OpenThread Border Router web gui working. I originally thought it did not work but was not including the :8080 in the URL. What worked was:

http://127.0.0.1:8080

This shows the FORM tab which makes your thread network. Since my Dongle does not work, this part can’t setup the network, hopefully this part will be easy when my other Dongles arrive.

I think once the Thread Network is created, I then use the Thread Commissioning App to add other devices.

I found out today that when installing Ubuntu applications for the desktop, the ones you don’t use a command line but just click on. You have to use:

chmod a+x filename.ext

before clicking on it. (This is standard behavior for running command line apps,I just never thought about needing to use it to run desktop apps)

I also found out that

ctrl-v

to paste HTML text is very different from

shift-ctrl-v

which pastes plain text (not sure why it took so many years to find that out) :grin:

1 Like

After reading the OpenThread articles, I followed a link to OpenLabs for an RPi mesh radio module. I ordered two. Now that I have them, I spotted that I have RPi Model 2, not 3…

https://openlabs.co/OSHW/Raspberry-Pi-802.15.4-radio $10(US) each.

" The module comprises a chip antenna, crystal oscillator, and an Atmel AT86RF233, which is a 2.4GHz SPI-to-antenna transceiver IC with 802.15.4 hardware assist. This is therefore an SPI-to-airwaves 802.15.4 solution.

The header pins are matched to pins 15-26 of the RPi P1 header, but this design is otherwise not RPi-specific. It would not be wrong to call this a simple AT86RF233 breakout board with an antenna and crystal. "

So, the AT86RF233 chip isn’t listed as a supported platform for OTBR (https://openthread.io/platforms/) but it may be useful to try to read it with SPI…

1 Like