Short circuit at voltage regulator

After plugging in my Photon to my desktop USB port and flashing code to it a couple times, I noticed that my Photon turned off and was too hot to touch so I disconnected it. When I reconnected, it got hot within a few seconds and the lights didn’t turn on. This happened with 4 Photons, and I tried different breadboards, USB cables, and USB ports on my desktop. My other Photons worked fine on my Macbook and another desktop, so I checked the voltage on my USB port and read 5.17 V, same as my other computers. When I connected it to a variable power supply, I could see that there was a short circuit in the photon. So I read the resistances between GND, VIN, and VOUT on the voltage regulator and saw that there’s a short between GND and VIN on one of them and between VIN and VOUT on another.

Interestingly enough, the third Photon started working again, and when I read the resistances between GND and VIN it was 1 MOhm, compared to 30 MOhm of a working Photon and under 10 Ohm of a totally dead one. This Photon operates at a higher current and higher temperate than a working Photon. The fourth Photon turns on but goes into pulsing white, which I think means that the Broadcom chip is dead.

Could the desktop have somehow destroyed the Photons or could my Photons have come with bad voltage regulators? I’ve never heard of power from a USB port on a working computer with working USB ports having damaged another device. The voltage regulators now have shorts in them internally but I can’t think of how the desktop could have damaged them.


wow i have never heard of 4 photons damaged at one go. I guess it was working fine until you changed the voltage source? 5.1V on the USB + source is fine. The recommend is 5.5v (

Try placing the pulsing white one in DFU mode. If you can do it, the Photon should still be working fine!

Try using other USB power source like a battery charger and see what happens?

The Photons were working fine with my other computers, USB wall warts, and lithium batteries, but somehow one of my desktops kept repeatedly damaging the Photons when it was plugged in via USB. It took me 4 Photons to realize it was the computer and not something else. I’m baffled by this, so I’m just going to have to avoid using this computer. Have there been reports of Photons being damaged by other computers?

I was able to put the pulsing white one into DFU mode and flash a new firmware, but that didn’t fix it. It is now blinking red and I’m unable to put it into DFU mode.

@r2jitu i have not heard reports like that and that’s super strange since i power up my Photon with self made USB hub :smiley:

How did you flash new firmware for the pulsing white one? particle update?

I wonder if @AndyW has some inputs here.

My theory is that the USB port somehow over-volted or over-currented the Photons, and the longer they were plugged in and exposed to the bad power source, the more the voltage regulator heated up. The heat could have caused it to melt internally and leak power between VIN/VOUT and GND.

The breathing white Photon is back to breathing white again. I was able to flash it using particle update again, but it made no difference. It also got hot after I left it plugged in for a couple minutes, which makes me think that it is leaking some current but not as much as the totally broken Photons. I read somewhere that breathing white on startup means that the ARM chip isn’t able to talk to the wifi chip, so maybe the wifi chip got damaged by the bad power source.

I can confirm the same issue. My Photon was working for half a year without any issues until I plugged it into my office desktop. After that voltage regulator started overheating. I thought I shorted it somehow so tried a second photon. Left it plugged in for a hour and completely killed it. Second Photon will not even turn on anymore. That is quite strange because not any other electronics get affected by the same computer. I think voltage regulator is incompatible with Photon design.

@laynd do you have a link to that power adapter that you used?

BTW: Double posting is not encouraged!

I didn’t quite understand the cause of this issue but I have been able to work around it by attaching a battery with 5V step-up to VIN to supplement the USB current. I was using servos in my project and small servos worked fine but I think it started failing when I switched to larger servos that use more current.