Photon Troubleshooting Guide (as of Firmware v0.4.6)

@christine thanks for your help.
my wifi router complies with the sepcs ( channel 6, no entreprise network, no captive portal, no complex network, 802.11 n retro compatible). I can see my photon is online on my router web page : it has been given an ip.
I’ve tried both firmware upgrades mode : manual and particle update.
If I understand well the led codes ( ) , it seems that my photon is crashing during an OTA.
the cycle is white (startup), flashing green (connecting to wifi), flashing cyan (connecting to particle cloud), then flashing magenta (receiving new firmware OTA), then white again.

I think it can communicate with particle cloud, but it crashes during the OTA.

How many magenta phases have you seen before you touched your device again?

A system firmware update consists of three to four cycles of the type you described and may take up to 15 minutes - even if everything works well.
If interrupted it might take even longer.

New Photon Updates: Magenta for 5-12 Minutes, DO NOT UNPLUG

Hello @ScruffR
thanks for helping me.

I let the photon on for a very long time (more than 1h) , this cycle keeps going on and on. it seems to me that the red flash is indicating SOS mode ( ) with 3 short, 3 long 3 short, and then 1 flash, and then again 3 short, 3 long, 3 short and then 1 flash, indicating error code 1 : # Hard

So it seems that the application firmware is causing some trouble.

To get around this, put your Photon into Safe Mode and wait till it connects to the cloud (breathing magenta).
After that just flash a very simple code (e.g. Blink an LED) via Web IDE.

If that involves more than one phase of magenta flashing you’ll get auto-updated and let the procedure finish for about 15min.

After this your Photon should be running your simple sketch.

The problem is that i’ve never seen my devices on the web IDE. When i put it in safe mode it goes back in setup mode (blinking blue). I then do the “particle setup wifi” process. then it goes into a cyan / orange mode. I’ve tried the “particle keys doctor” process to update my keys, but both photons came back into cyan/orange after this operation.

Discouragement is not far on my side… it may be one of the poorest techie experience i’ve never had, something between windows Me and Vista…

Windows me ? , surely not that bad !!!

1 Like

I’m stuck with two failed photon and will probably have to ask for a refund. What a poor experience !

1 Like

Sorry to hear you’re photons are not working as expected. Have you taken any troubleshooting steps so far?

@mdma thanks for helpin. did you read my precedent posts in this thread ? Yes, I’ve spent hours in troubleshooting. I’ve spent also some time with Harisson from your support team by email, but I have no news from him since 5 days.

So it seems you’re suffering from fast blinking cyan with blips of red/orange in between? Having a short video of that would be great, since the colors are easily confused (as experience has shown).

If you’re willing to give it another shot, could you try the following?

  • update the CLI using npm update -g particle-cli
  • put the device in DFU mode
  • issue particle update using the CLI.

That should get you on the latest firmware. Should problems proceed to exist, give the following a try:

If that doesn’t help;

If possible, could you try setting up a hotspot with your cellphone to rule out unforeseen router issues. For some reason mobile hotspots are ‘simpler’ and tend to work well.

Please @christine I tried following your steps but i got stucked at the point of flashing the part 1 and 2 as whenever i tried, it keeps displaying “dfu-util: Could not open file system-part1-0.4.6-photon.bin for reading: No such file or directory”. I don’t know if I will need to create a new file and download the firmware binaries into it. Please can you assist me in this?

@luckygodswill There are clearer instructions here. If you have trouble even after trying these things, email for more help.

You should first CD to the directory the downloaded .bins are in, or the command line won’t be able to find them, and thus report that they don’t exist.

Alternatively, you can follow the steps in my post above, and use the Particle CLI, which should do the same thing.

1 Like

I’ve spent a couple of hours trying to resolve a problem that showed up after I was happily programming my Photon. My Photon has the latest firmware. The problem showed up about the time I was attempting to use the random function.

Suddenly, I was getting some flashing that looked like a reset and attempt to connect to the cloud, but instead ends with a red SOS flash, followed by 5 error flashes. This is “Usage fault,” but I have no idea what I should do to fix this.

I attempted to do a factory reset, but no matter how long I hold down the setup button, I don’t get past the DFU rapid yellow flashes.

When I attempt to reflash the firmware using dfu-util, I get the following message:

$ dfu-util -d 2b04:d006 -a 0 -s 0x8020000 -D system-part1-0.4.6-photon.bin
dfu-util 0.5

> (C) 2005-2008 by Weston Schmidt, Harald Welte and OpenMoko Inc.
> (C) 2010-2011 Tormod Volden (DfuSe support)
> This program is Free Software and has ABSOLUTELY NO WARRANTY

> dfu-util does currently only support DFU version 1.0

> Filter on vendor = 0x2b04 product = 0xd006
> Cannot open device 

However, dfu-util can find my photon:
~$ dfu-util -l
> dfu-util 0.5

> (C) 2005-2008 by Weston Schmidt, Harald Welte and OpenMoko Inc.
> (C) 2010-2011 Tormod Volden (DfuSe support)
> This program is Free Software and has ABSOLUTELY NO WARRANTY

> dfu-util does currently only support DFU version 1.0

> Found DFU: [2b04:d006] devnum=0, cfg=1, intf=0, alt=0, name="UNDEFINED"
> Found DFU: [2b04:d006] devnum=0, cfg=1, intf=0, alt=1, name="UNDEFINED"

How do I un-bricked my Photon ?

Looks like your using a very old version of dfu-util have a look for a later version, i think 0.8 came out 18 months ago

try safe mode since most likely the error is in your application. there should be no need to reflash system firmware.

Thanks for the responses.

@Hootie81 -
When I used dfu-util 0.8, I get the following error messages:
dfu-util: Invalid DFU suffix signature
dfu-util: A valid DFU suffix will be required i a future dfu-util release!!!
dfu-util: Cannot open DFU device 2b04:d006

@mdma - I really wish I could get my photon into safe mode. However, no matter how long I hold down the setup button, and no matter how much a plead, beg and threaten my photon, it will not progress past DFU mode.

Further suggestions please? Or is it time to send my photon off to the big brick yard in the sky and maybe appeal for a replacement?

Have you installed the DFU driver using Zadig?
maybe just double check the libusbk version… see here

That might be because Safe mode comes BEFORE DFU mode. Thus, if you’re at DFU mode, you’re too far already.

1 Like

Head slap!

Yes, @Moors7, problem solved.