Photon Problem - http.get(request, response, headers) Causing reset

I have a working Photon application that posts data to our cloud db via our rest API. So yesterday when I flashed the app to a new Photon I got compile errors due to the new Particle Firmware which really caught me off guard, which I fixed and then successfully flashed the device. Then after the app started it worked fine getting and posting data via our rest API. Then the app unexpectedly reset on the following line of code:

http.get(request, response, headers);

I have several other functions in this app calling this same line of code without any problem. The only difference is the rest URL or Host Name string in the problem instance is about 50% longer than the ones that execute successfully.

Maybe the 0.4.5 or 0.4.6 firmware release restricts the size URL/Host Name? This application has worked flawlessly for several weeks. Its also peculiar that this line of code forces a reset.

Thanks in advance for any help!

NOTE: I just rolled back to firmware version 0.4.5 and my application works normally again. Something must have changed with http.get or something related or required of that function?

Something’s not working right in the TCP client on 0.4.6. See this isssue on GitHub:

You should probably keep using 0.4.5 until 0.4.7 is released.

I have inestability problems with http client (firmware version 0.4.7). I have exposed in troubleshooting section: