I've got Build figured out, but need help with troubleshooting

Hello, pardon my ignorance and thank you in advance for your help.

I am new to Photon. I have managed to get one programmed (using Build) and connected to Blynk. My basic sketch (?) works exactly as I expected. However, as I have tried to refine it, I have run into some issues and need to troubleshoot outside of the cloud interface to Blynk.

In examples, I see things like “Particle.publish”, “print()” and “write()”. From the context of the examples, it looks as if these are happening sort of in parallel to the WiFi interface. My question is: How are these used and where does the output appear?

Second issue:
Guessing it had to do with the Command Line Interface (CLI) I have a couple times to figure out how to load and use that. After an aborted attempt on Sunday, I tried again today. I actually got the “npm -g . . .” command to run, but it spewed about two Windows cmd pages of error messages, crashed my computer, corrupted my boot drive and (maybe coincidentally) caused my RAID drive to go critical. After Windows re-booted and ran chdsk, I tried to uninstall node.js and it hung and crashed my computer again.

My first task is to repair my Raid array. Then back up my system. When I have finished all that, I’ll get back to working with my Photon.

In the mean time, if any of you can guide me through how to use commands like “Particle.publish” I would really appreciate it.

Thank you

Take a look at: https://docs.particle.io/reference/firmware/electron/#particle-publish-

You can view the output at http://console.particle.io/logs

To install CLI on Windows I’d recommend using the Windows Installer

With CLI you can use

particle serial monitor --follow

to get the Serial.print() output.
Since 0.6.0 you can also use the Log..... feature to get debug output via USB Serial (or other ways like papertrail)

To read the USB Serial output and interact with your Photon via USB Serial, you can use any other serial terminal program (e.g. PuTTY) too.

kenneth & ScruffR - Thank you for your replies!!

My understanding how getting Particle.publish to post into the Console provided the troubleshooting messages I needed to get my Blynk communication figured out. (Turns out, my problem was not in setting up the connection, but apparently going to Sleep before the link to Blynk finished updating. By adding a delay before the Sleep, everything worked. :grinning:)

Also, after reloading the Particle drivers for the third time, I finally got Photon to show up as COM7 and got PuTTY working. After spending a couple hours this morning, I was typing a list of questions about getting it to work, but thought I’d try one more time before posting. I guess the third time was a charm.

Thanks again.