FastLED not compiling to Photon

Try CLI with the switch --target 0.6.0

@enjrolas Just checking to see if you have tried 0.6.2-rc.1 with FastLED. We would like to make this the default firmware soon so I’d appreciate it if you can give this a test today or tomorrow and let me know if things are working for you :slight_smile:

Works for me with the Internet Button and this code:

#include "FastLED.h"
#define NUM_LEDS 11
void setup() { 
    FastLED.addLeds<NEOPIXEL, WKP>(leds, NUM_LEDS); 
    for (int x=0; x<NUM_LEDS; x++) {
        leds[x] = CRGB::Cyan;

Is it possible to test this with Particle Dev? My project is not easily transferred to the Web IDE.

If you update Dev to the latest version (1.8.0) you should be able to select 0.6.2-rc.1 as the build target version

Compiled successfully on 0.6.2rc1 with my existing FastLED project, which had been broken before.

EDIT: This project lives in the Web IDE.

I had stepped it down to 0.6.0 and included Particle.h in order to be able to continue to make updates to that project on my side, and followed this thread so that I would know when I could set it back to using the current firmware.

I haven’t run the project through its full paces, but it verified and flashed just great. Big sigh of relief from me. Thanks!


Great! My project (which was severely busted in 0.6.1) also compiles and flashes without any problem with 0.6.2-rc.1.


Confirmed - this works now for me too with 0.6.2-rc.1

1 Like