Building Debug Builds Error. 'doc topic - Debugging with Eclipse'

I was able to reproduce that error with 0.6.2 for Electron with the options:


I would create a Github issue in the firmware repository for it. It worked properly with 0.5.3.


@rickkas7 I have opened a github issue regarding this at:

I was able to build with MODULAR=n DEBUG_BUILD=y and USE_SWD_JTAG=y against release 0.5.3, as advised by Rick. This allowed me to use SWD debugging using a SEGGER J-Link.

I will build against this for debugging purposes, and compile against latest when I am ready to install my device. Thanks y’all!

Hi There

I note that this issue has been fixed? on github, but I have tried pulling the development, and the feature/photon/wiced-3.7.0-7 versions and neither of them compile. it seems that the tls stuff is now broken, I’m just doing a basic build, and nothing flash I was really wanting to debug my own application in eclipse using the 0.6.2 firmware on the electron.

I using the recommended 4.9… Version of GCC

Could someone guide me in the direction that I should head, in order to get it to compile.