Argon reading zeros from dht22/ dht11

I hadn’t tried 5v until a day ago and and still had issues before that

I have a boron and a couple xenons sitting around I should try it on those

Personally, I use @rickkas7’s DHT22Gen3_RK library *(also available on the Web IDE) which has given me zero problems.

1 Like

I will give that a go see if I can make it work

As mentioned, I have been running the PietteTech_DHT library just fine (<10% error rate), so it’s most likely not the library and trying another lib without knowing why an otherwise working lib doesn’t work seems like trying every tablet you got in your medicine cupboard without first knowing what’s causing the ailment :wink:

1 Like

Well Im new to this so you’ll have to be patient with me im trying to learn :upside_down_face:
But it didnt work anyway the main issue with the PietteTech_DHT library im having is i cant get it to even initate a read it will just upload the code and the events reads success the sensor is cycling a reading every 2 seconds according to my meter but it doesn’t show up in the events

Then it would be best to take things in small steps.
This is what my code would show.

Take this project, hit the COPY THIS APP button and flash it to your device.
Then unplug the device, plug your DHT22 sensor directly next to the Argon aligning the sensor pins with D2 (-) D3 (out) D4 (+)
When you then power up the device again and connect it to your computer via USB and watch the Serial output via particle serial monitor --follow you should see valid readings.

When you just click the link you will get a Web IDE project ready to use.

Desktop IDE (aka Particle Dev) is being discontinued and should be replaced with Particle Workbench (VS Code).

Sorry for all the time in-between responses, but has been a busy spring around here
anyway I got the sensor working using ADAFRUIT_DHT_PARTICLE that showed return reading of 0 temp and 0 humidity but it did read the sensor i tested it with a multi-meter.
Since im a noob at coding i then started replacing code and used code from ADAFRUIT_DHT library and that fixed it. Now im wondering if someone could explain to me why that fixed it.
Below is the code that fixed the problem. thanks


```DHT dht(DHTPIN, DHTTYPE);
int loopCount;

void setup() {
	Serial.begin(9600); 
	Serial.println("DHTxx test!");
	Particle.publish("state", "DHTxx test start");


	dht.begin();
	loopCount = 0;
	delay(3000);
	
}

void loop() {
// Wait a few seconds between measurements.
	delay(2000);