Core not getting online

I have an original Kickstarter Spark Core that I never used, but figured I’d try it out for a project now. Smart Config fails, so I’ve followed the guide an used a terminal & USB instead. I supplied my wifi credentials and the LED now follows a sequence like this:

  • 3 x Slow blink White
  • 1 x Fast blinking Green
  • 3 x Fast blink White

After this, it stays solid magenta (no blink/fade). According to the guide, it should blink magenta and do an update, but it does not. The first time, I left it like this for two hours with no noticeable change.

I’ve also tried to do this via the command line tools to no vain. It does just the same - stays magenta.


Since your Core is one of the first ones you’ll need to either connect it to a WEP network or perform a DFU deep update before connecting to an open/WPA/WPA2 network.

But for the basics have a look here

I get solid magenta when using a factory firmware (without deep update) with correct credentials against my WPA2 network.


Worked like a charm - thanks!


Good to hear :+1:

For the benefit of other users who might experience the same problem, which of the suggested routes did work for you?

Set your network up as WEP or perform deep update via USB?

If it was the WEP route, did your Core pull the deep update via cloud automatically and can you also use other WiFi settings now?

I used the USB-route. I published a bit on it here so that others looking for a solution will find it via Google eventually.