Xmas tree + photon + setup= brick

Don’t plug your fresh out of box photon into the xmas tree shield and attempt to setup the photon. I pushed the joystick and the LEDs dimmed on the photon for a second after completing setup and the photon reset to flashing green. It lost it’s setup - digital lobotomy.

When attempting to re-setup the photon I am unable to claim the device now. It will flash cyan then red then repeat a few cycles then continue to flash cyan fast. I tried everything listed in the forum to reset the photon without success. DFU mode reflash, reclaim key, holding reset for 10 seconds, none of it worked.

Lesson learned the hard way.

1 Like

You sure you put the Photon into the headers in the correct orientation?

Yes, USB connector towards the top of the tree. I’m an EE for the last 20 years. Orientation is key to success.


So it’s working now that you programmed it unattached to the Tree?

No. Like I stated above after the reset by the joystick I’m unable to claim the photon. I failed to state above I remove the photon from the tree shield for all attempts to reclaim the photon. So far nothing has worked.

To put your Photon in Listening Mode, hold the SETUP button for three seconds, until the RGB LED begins blinking blue.

Have you tried that?

This is the problem I am having. No luck in fixing it. I have written off this photon as lesson learned.My post is a warning to others that do not setup the photon when plugged into the tree shield.

I don’t think that should happen to you.

@rickkas7 @ScruffR

Can you post the output (including the exact command) of

particle --version
particle update
particle keys server
particle keys doctor <yourDeviceID>

and maybe a video of the actual blink pattern?

1 Like

Yes, that shouldn’t happen. I put a brand new Photon in the Xmas tree, set it up with the iOS app, then when the setup completed, pressed the joystick in various directions and it was fine.

It seems like a fluke where probably a power glitch caused the settings to be reset, but ScruffR’s recommendations are a good place to start.

As long as the USB interface still works and you can switch modes it’s almost always possible to recover the device, but if not create a support ticket and include a link to this post and we can either get it working again or replace your Photon.


Version is 1.19.4

particle update

Your device is ready for a system update.
This process should take about 30 seconds. Here goes!

! System firmware update successfully completed!

Your device should now restart automatically.
You may need to re-flash your application to the device.

particle keys server
Found DFU device 2b04:d006
spawning dfu-util -d 2b04:d006 -a 1 -i 0 -s 2082 -D C:xxxxxxxxxxxxxxxxxx\Local\particle\node_modules\particle-cli\keys\rsa.pub.der
dfu-util 0.8

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2014 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to dfu-util@lists.gnumonks.org

Opening DFU capable USB device…
ID 2b04:d006
Run-time device DFU version 011a
Claiming USB DFU Interface…
Setting Alternate Setting #1
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 4096
DfuSe interface name: "DCT Flash "
Downloading to address = 0x00000822, size = 512
Download [=========================] 100% 512 bytes
Download done.
File downloaded successfully
Invalid DFU suffix signature
A valid DFU suffix will be required in a future dfu-util release!!!
Okay! New keys in place, your device will not restart.

particle keys doctor xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
Found DFU device 2b04:d006
Found DFU device 2b04:d006
Error creating keys… Error: Command failed: C:\WINDOWS\system32\cmd.exe /s /c
"openssl genrsa -out xxxxxxxxxxxxxxxxxxxxxxxxxxxx_rsa_new.pem 1024"
‘openssl’ is not recognized as an internal or external command,
operable program or batch file.

Make sure your device is in DFU mode (blinking yellow), and that your computer i
s online.
Error - Error: Command failed: C:\WINDOWS\system32\cmd.exe /s /c “openssl genrsa
-out xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx_rsa_new.pem 1024”
‘openssl’ is not recognized as an internal or external command,
operable program or batch file.

If you get this error under Windows:

'openssl' is not recognized as an internal or external command, operable program or batch file.

and you installed the CLI using the Windows CLI installer, it may work if you do:

cd c:\OpenSSL-Win32\bin
particle keys doctor YOUR_DEVICE_ID

Needed to re-install openssl then it generated a new public key. Seems like its working now.


For future problems updating CLI to 1.27.0 (or later) might be a good idea.

If you previously installed CLI via the Windows CLI Installer you can do

particle update-cli
1 Like

I just tried the Particle update-cli and I ended up getting this:

I then downloaded the CLI windows installer app and ran it but still get this same message when I try to run the suggested Particle Setup.

How do I install the Serial again? I never deleted it?

If you had CLI installed via npm you need to uninstall all instances of CLI first before installing via the installer.
The setup will only work on a clean machine.

But to install the missing module you could try

npm install -g serialport

I fixed it by uninstalling the Windows Particle CLI Application from the Windows Application removal area in the control panel.

Then I installed the new CLI via the Windows installer.

All good now :spark:

1 Like

By the way: my XmasTree works like described out of the box.

1 Like

Now we just need a custom design like the tree for all the different holidays :smile:

@zachary @zach @Dave @mohit @BDub @jvanier @will

After this first tree experience are you guys open to making some other similar designs for other holidays like Haloween? Not sure what other holiday people get really excited about other than Christmas and Haloween.

Just a thought. The Christmas tree was pretty special and unique and everybody that saw it talked about since it’s kinda hard to miss those vibrant DotStars.