Xenon nodes lose internet connection when argon has system mode set to manual or semi-automatic

argon
xenon
Tags: #<Tag:0x00007fe222f52ad8> #<Tag:0x00007fe222f52768>

#1

I have a simple setup with an Argon gateway running some basic code (flashing a NEO and posting to Blynk)… I have it set to either MANUAL or SEMI-AUTOMATIC mode and running separate system thread. I also have two Xenon nodes configured in the mesh network. No code yet running on the nodes. If I run the Argon in AUTOMATIC mode, all is well: all the nodes breath cyan and are happy. If I set the Argon to either MANUAL or SEMI-AUTOMATIC modes, the nodes will lose internet connection and fast-flash green… The Argon continues to breath cyan… I’m executing the Particle.process() function every second (as indicated by the argon continuing to breath cyan) is these something else I need to do to keep the nodes connected to the internet while Argon is in MANUAL or SEMI-AUTOMATIC mode?


#2

What device OS version are you running?
Does your Argon actually have an active cloud connection (e.g. send a Particle.publish() heartbeat)?
Or could the breathing cyan just be wrong?


#3

I was running 1.4.0 on the Argon with both Xenons at 1.1.0… I have since updated the Xenons to 1.4.0 and a simple NEO blinking code. Results are the same: in either non automatic mode set in the Argon, both Xenons will start a fast cyan flash and, in perhaps 30 seconds or so, followed by a fast green flash… the Argon remains in breathing cyan and is continuously updating the Blynk app which signifies that it is connected to the internet. I do a ‘network check’ function every second issuing a Particle.process() function in the Argon and send a Particle.publish(“GW”,“ping”) every second as well. Once I set the Argon mode to AUTOMATIC and flash, both Xenons immediately connect and breath cyan.


#4

To help us understand the issues - you need to post the application on the gateway (ARGON) and on the endnodes (XENONs). For what it is worth I am running a gateway on a XENON in an ethernet featherwing using AUTOMATIC and endnodes using SEMI_AUTOMATIC. I only use mesh pub:sub between the gateway and the endnodes. I have noticed that sometimes if the gateway is reset the endnodes will flash green even after the gateway is happily breathing cyan. It maybe you need to implement a re-connection process for certainly MANUAL and possibly also SEMI_AUTOMATIC (which should not be required).


#5

Thanks for the response! You can see the issue with just a simple blink the LED code on all three… I’m doing the opposite of you: putting the Argon in a non-automatic mode (adding the Particle.process function to keep the cloud connection) and leave the Xenons in automatic you will see the Xenons drop out and fast blink cyan followed by fast blink green. Is there something I need to do on the Xenon side? I would have thought, being in automatic mode, they would connect as needed.


#6

It is very difficult to give an opinion on what might be causing the issue without seeing the code!

If you were using SYSTEM_THREAD(ENABLED) then there would be no need for the Particle.process().

If you have a sleep process then Mesh.connect() is needed after waking - but in that case you would see a white LED.

Have you fitted external antennas and enabled their use (ARGON and XENONs)? You may be losing mesh signal?