Xenon devices starting up in safe mode

xenon
Tags: #<Tag:0x00007f038c850ae8>

#1

I can’t get my Xenon mesh devices to start in normal mode. They are both starting in safe mode only (irregular flashing magenta). They are both connected to a mesh network from my Boron (breathing cyan) which seems to be working fine.

I’ve flashed simple code onto the Xenon boards. The code really doesn’t do anything. I’ve also tried flashing the default blink code with the same results.

long next = 0;
//int counter = 0;
//char *data = {};

void setup() {
    Serial.begin(9600);
}

void loop() {
    if (millis() > next) {
        next = millis() + 2000;
        /*if (++counter > 5)  counter = 1;
        itoa(counter, data, 10);
        Mesh.publish("ledBLink", data);*/
    }
}

When the devices start up there is a diagnostic event in the log with weird memory sizes. It says used memory is negative??? Also, total memory is only a small portion of what it should be.

{"device":{"system":{"uptime":6,"memory":{"total":32768,"used":-76712}},"cloud":{"connection":{"status":2,"error":0,"attempts":1,"disconnect":0},"disconnects":0,"publish":{"rate_limited":0},"coap":{"unack":0}}},"service":{"device":{"status":"ok"},"coap":{"round_trip":742},"cloud":{"uptime":0,"publish":{"sent":1}}}}

#2

@cliquot22, what DeviceOS are you using on the devices. It is quite possible that when you flashed your code, you changed the version. This would cause Safe Mode healer to kick in and download the new DeviceOS, giving the “irregular” flashing magenta. Upgrading the DeviceOS takes some time over mesh so you need to give it several minutes to be sure.


#3

That was the problem. The device has 0.8.0rc26 and I was trying to flash 0.8.0rc27. Once I changed the target in the webIDE it worked. Thanks.