windows7 Photon driver installation "access is denied" [Solved]


#1

When I try to install the Photon driver, so I have virtual COM port, I get “access is denied.”
During Driver Update, for window "Update Driver Software - Photon with WiFi
I choose this (note: “driver has Authenticode signature”


#2

Can you run it as administrator?


#3

Still access is denied.
I did:
Start > Control Panel > Device Drivers > Run as admin

I selected Photon.inf


#4

UPDATE:
Today, I successfully installed the driver onto my Windows-7 laptop.
I tried again to install the Particle Driver onto my Windows-7 Desktop, but again got “Access is denied”.

NOTE: On same desktop, I have also been doing development on an STM eval board using mbed IDE and associated virtual com port. Could this cause a conflict with Particle?


#5

@peekay123
Do you know why @douglaskbell can’t install the drivers on his desktop?


#6

@nrobinson2000, I’ve been watching this thread and holding off. In my experience, windows can be a pain with COM ports. In cases like these I would normally run this from a command prompt running as adminstrator:

set devmgr_show_nonpresent_devices=1
devmgmt.msc

Then in device manager, select “Show hidden devices” and delete all photon/electron/core related COM ports and their drivers. I usually disconnect all my devices before I do that. After that, I replug devices and let the drivers reinstall themselves or, when necessary, reload the Particle drivers manually. If that doesn’t clear things up, you may need to enable unsigned drivers.


#7

Also just to make sure, the driver zip was completely unpacked and not only in a temp directory of Explorer :wink:


#8

@douglaskbell, were you able to get the drivers installed?


#9

I did what peekay123 said: delete all the particle COM ports (right click delete), but still get “Access is denied” when I do Update Driver Software - Phton with WiFi.

Is it possible to run the driver update with admin privaledges? I will try…

Ah, hah!
PROBLEM: My folder that contains the driver was encrypted, and possibly read-only.
SOLUTION: Made it writable and non-encrypted.
Installed.


#10

Sounds good!


#11

@ScruffR The drivers (three versions) down load to a Temp file. How do I get them installed.?


#12

By following the instructions :sweat_smile:?
If you do get stuck somewhere, let us know where and how.


#13

get stuck installing on Wondows 7 x64.
It doesn’t find the driver in Spark directory.