Wifi Connected but Photon status is offline [SOLVED]

So I have a Core and a Photon. The Core is working fine, comes up as online. So I believe my internet and wifi are fine.

The Photon was working fine last week but I got it out today to play with and it will not go Online.
It is connected to my wifi, I can download tinker from the online build tools (build.particle.io).
The Tinker iPhone App says it is offline. The WIndows & Linux Particle CLI says it is offline.

I have performed a factory reset and reclaimed it via the iPhone tinker app. It’s status still says it is offline.

I want to update to the new firmware but the Dfu-util does not seem to find it on Linux, and I cannot find a site online that has a windows binary of Dfu-util. SourceForge it offline. The git repos I have found do not work.

Any suggestions?

Well after more googling I found a link to here
tutorial intalling dfu driver on windows

And this seems to have solved my problem once I upgraded to the latest firmware 0.4.3

1 Like

Thanks for reporting back. That’s great to hear the latest release fixed your issue! :+1: