[Webhooks] Super Simple Motion Activated Push Notifications

Just follow the same instructions for an electron :slight_smile:

2 Likes

New to the club here.
Walked through the instructed post, not working for me.
.ino is ok
The reply from

CLI is not exactly the same (I don’t mean the keys)

I ensured the hardware is ok by connecting a wire from 3.3v and tap it directly to D0

Tested the Pushover email function, all good.
What did I miss?

@Mike6745,

when you test it wtih the CLI like this:

particle publish "office-motion" "this is a test"

do you get a pushover message?

CLI says it published but I never received it

In my Pushover>Your Applications
It lists as Messages sent 0/7,500

Is there anything else I could try? I’d really like to get this going.

You might want to watch the webhook response at https://console.particle.io/logs and figure out the issue.

@Mike6745

Try these commands:

particle webhook list

Make sure your webhook ID 57cff0abd6df53857e7456ad still exists. If so, delete it:

particle webhook delete 57cff0abd6df53857e7456ad

Then re-add:

particle webhook create Push1.json

Open the event stream to monitor:

particle subscribe mine

And test simply with:

particle publish "office-motion" "test"
1 Like

how to open up a terminal and navigate to where you saved the pushover.json file.
I got pushover.json not found msg
in particle cli after write particle webhook create pushover.json command in particle cli.
It would be helpful if you assist for solve this query.

It depends on your operating system, but if you google for ‘navigate console/terminal’, you should be able to find out rather quickly.

[quote=“Moors7, post:36, topic:10322”]
navigate console/terminal

Thanks for quick response. I used windows operating system.
How to troubleshooting “pushover.json file not found” problem.

You need to navigate the command line to the directory the file is in.
Let’s assume the file I’m looking for is in “C:\Users\thebe\Documents\particle\firmware”.

If you open the command line from the run window, you’ll end up in your home directory (C:\Users\thebe).
You’d the use the cd command to get to the place you need to be:

I followed your instruction. still i get “pushover.json is not found” error.

That is because your file is called pushover.json.txt.
You need to remove the .txt extension.

I hate to say, but the default Windows setting to hide known extensions is a stupid thing as it causes things like this.

I’d always deactivate that setting in Windows.

1 Like

Hi there,
When I try to create a new webhook I get this error. I’m fairly new to all this, so I’m not sure how to interpret it, and I was wondering if you guys knew how to fix this. To give you some background of what I did: I opened a textedit file, copied the code above and added my user key and API token, then saved as pushover.json as directed. I also do have Particle CLI setup. Any help would be greatly appreciated!

The error (quite obviously) states there’s a syntax error, so you might want to double check your JSON for any invalid characters. If you do a quick Google you’ll find a couple of sites that can check JSON for you that might be of help :slight_smile:

3 Likes

You can also add a Webhook now with the Console, which might be easier :slight_smile:
https://console.particle.io/integrations

2 Likes

Still not sure where the syntax error came from, as I simply copy and pasted the code above and added my user ID and API token, but I got it to work with the console! Thank you guys for your help!

2 Likes

Hmm, that’s odd. Just tested it (the JSON blob from post 1) here and it created successfully. Perhaps your editor changed the quotes to something odd? Either way, glad to hear you’re up and running.

10 posts were split to a new topic: Setting up Webhooks with Particle CLI and Particle Console?