WaveShare 1.5 inch RGB OLED with SPI on Argon invalid conversion from 'uint16_t'

Well, thanks again. I really appreciate the help.

All the best - David

1 Like

hey @ScruffR sorry for turning this into an unrelated support thread, but I can’t seem to publish it. particle login worked fine, but upload and publish both failed:

C:\Users\nfriedly\projects\Adafruit_SSD1351_Photon>particle login
? Please enter your email address <snip>
? Please enter your password [hidden]
> Successfully completed login!

C:\Users\nfriedly\projects\Adafruit_SSD1351_Photon>particle library upload
Network error from https://api.particle.io/v1/libraries

C:\Users\nfriedly\projects\Adafruit_SSD1351_Photon>particle library publish
Network error from https://api.particle.io/v1/libraries

Any ideas? I could try from a linux or mac machine, but if it’s a network error then I don’t know if that will help…

I only installed the particle-cli tool from npm, do I need the drivers and other things?

For uploading you wouldn’t need any drivers installed but for Windows it’s best to install CLI via the Windows installer (after removing any previous versions).

Command Line | Tutorials | Particle

Do other commands like particle list work?

Hey, sorry it took me a while to get back to this. I tried it on another computer just now and everything worked, so the new version with a github link and updated Adafruit mGFX library is now published.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.