Viperized Photon, then reverted, now Photon's just blinking blue

Hi folks,

So like the title suggests, I viperized my photon and reverted due to it not working correctly. However, I’m stuck with a flashing blue light. I’ve tried a firmware & factory reset, but it’s still blinking blue. I’ve tried flashing the 0.4.2 & 0.4.3 releases hoping that that would fix the issue, but still no luck. Anyone out there have any clue as to other steps I could try here?

Many thanks in advance.

Blinking blue is listening mode. You need to give it credentials for wifi. Try either the app or the CLI with particle setup [wifi] (where the wifi part is optional).


Hello asachs,

exactly as Moors7 said. You need to claim your Photon via the app (or CLI). The Viper IDE restores the original status of the Photon, as it was when you first unbox it. Except that the keys are not touched, so if you have changed them, they are still there.

@Moors7 @Giacomo

Thanks guys! Yeah, I’d gone through just a vanilla setup, but that didn’t work. The particle setup wifi did the trick.

1 Like