Using Raspberry Pi Zero W is compatible?

This is great.
It is something that I must to try next. :smiley:

1 Like

All the best toys arrive when I’m between jobs.

1 Like

This one is priced very decently though :smile:

1 Like

I got my Raspberry Pi Zero W today.

After an hour of setup (soldering, flashing the sd card, using an hdmi monitor and keyboard to enable SSH, configuring the pi to my preferences, and installing particle-agent), I am now happily tinkering away with my Pi Zero W.

The installation was successful and Particle is running well on my Pi Zero W. I am able to do the same things I can do with my Pi 3.


Did you get the on-board LED to light with tinker? I got the particle agent installed with no problems but no on-board Blinky. I have some photons but this is my first time connecting a pi to the particle cloud.

Yes, the onboard Raspberry Pi LED is accessible on pin D7.

void setup()
pinMode(D7, OUTPUT);

void loop()
 digitalWrite(D7, HIGH);
 digitalWrite(D7, LOW);

Thanks, I got it working. Needed to apt-get upgrade and then it started behaving.

If you’re using Jessie, you can do it fully headless. You can place a file called ‘ssh’ in the root of the card, and well as a wpa_supplicant.conf file with


And you should be good to go. At least, that worked for me :smile:


I set up my wifi this way by directly editing the sd card, but I was unaware that SSH could be enabled this way.

I am using Raspbian Jessie Lite, released in March 2017. They now have SSH disabled by default which is annoying.

Ultimately it would be best if there was a utility for setting up a SD card properly (set up Wi-Fi, install particle-agent, change hostname, change password, enable SSH, etc). I think @jvanier was thinking about this, incorporating it into particle-cli perhaps.


I documented this in the Raspberry Pi getting started guide - Headless Wi-Fi setup for now

1 Like

I documented this over on my blog and on Hackster. There are few more things that need to be added to the Headless Wi-Fi setup on the Particle Docs.

@jvanier, I’ve just whipped up a script that automates the headless setup process.

It only works on Linux because only Linux can mount the Raspberry Pi partition.

I tested it with a freshly flashed SD card and my Pi 3 and it worked perfectly.

The incredible @nrobinson2000 strikes again!

I think the boot partition can be mounted on Windows and macOS since it’s FAT so you can create the ssh and wpa_supplicant.conf on any OS. I’ll check on a different machine.


wpa_supplicant.conf is on the Linux partition in /etc/wpa_supplicant/wpa_supplicant.conf So without mounting the linux partition you would only be able to enable ssh but not setup wifi. Pretty useless if you ask me. This is one of those times when I wish every OS supported linux filesystems.

Recent versions of Raspbian have been auto-magically copying /boot/wpa_supplicacnt.conf to /etc/wpa_supplicant/wpa_supplicant.conf at boot as well as interpreting /boot/ssh to enable the SSH service to allow most OSes to do headless setup of Raspbian.

Try it out and report your findings here! You may be surprised at the ingenuity of Raspberry Pi engineers in spite of the fact that not every OS supports Linux filesystems :smile:

1 Like

This is how my script enables SSH.

I’ll see if this works.


This works. It appears to copy /boot/wpa_supplicant.conf over /etc/wpa_supplicant/wpa_supplicant.conf and then delete /boot/wpa_supplicant.conf on boot. Is it possible to change the raspberry pi hostname with a similar method?

Trying it out now on a Raspberry Pi 3 B to go fully headless.
The machine I am using to edit/setup the SD card is Windoze.
I should be able to confirm once I have a suitable power supply on hand (need more amps).

Thanks for all the hard work in figuring out these nuances @jvanier, @Moors7 and @nrobinson2000 !


D7…uhm…Request GPIO chart… Confused. which analog and digital pin in pi?

Take a look at this link in the docs for pin definitions:


I finally received my power supply for my new RaspberryPi 3.
Since it is absolutely brand new, it has the latest version of Raspbian.

I can confirm that the behavior of /boot/wpa_supplicacnt.conf works exactly as you described.

1 Like