USB Uart corrupted?


#1

Hey All,

I was wondering if anyone has had this problem before. Im using a mac pro and have connected a p1 via usb using a usb adapter.
I had the P1 connected to the usb adapter (using the serial monitor in terminal). I believe i accidentally connected VCC to GND while the usb was connected and this caused the usb adapter to auto turn off (hdmi on the same adapter turned the display off).

After that happened, I released that now my p1 doesnt get recognised by the MAC. I plugged another p1 and it was working fine(not a problem with the usb adapter).

NOTE: neither the usb serial or DFU is not being recognised . Is there a possibility that i maybe I destroyed the USB part of the chip?

Things I have already tried:

  1. Opened Serial monitor (no sucess, not opening port)
  2. used command dfu-util -l in terminal while device in dfu mode. No device is recognised .
  3. Programmed the bootloader and system files using a jtag and STlink device

What else can i try?

Note that the device is connecting to the cloud and other tasks are working normally.


#2

@Div_IoT, there is a very high probability that you have stuffed your P1…


#3

Yea i thought so too. Strange that everything else works fine.


#4

I had a the same symtoms on two electrons. In my case reflowing the solder on the electron usb connector solved the problem. Nothing obvious was visible using a magnifying glass.