Unable to set up Boron LTE


#34

But if you have another mobile phone/device… It’s worth a try too! Might get you up and running right away (if the ble works well)


#35

Huge thanks to @kennethlimcp for helping to troubleshoot this one. From the screenshot you shared it seems like there’s something wrong with the BLE handshake process.

We’ll have to get one of our mobile developers to take a look at this. @jensck is likely the right person to weigh in next week.

Thanks for your patience – we’ll help get the issue resolved as quickly as we can :+1:


#36

Thanks for the detailed report + debug logs, @cairn – much appreciated!

It looks like the handshake process is timing out, which narrows things down a bit. I’ve filed a bug and will look into it!


#37

Any followup on this? I’m getting the exact same problem with both of my boron lte’s. Using android phone as well. Samsung S6.


#38

We are aware of it, but I don’t know if anything is out just yet. With last week being Thanksgiving, there has been some delays with some of our team travelling.

It’s most certainly on our radar though and I’m hoping to see some developments this upcoming week.


#39

Particle’s Android dev here with a status update:

I have a Nexus 6 in hand now, and I can reliably reproduce this bug, which will help me gather more information on the problem. Thanks much to everyone who’s reported this.


Argon/Xenon - Particle App 2.3.{6,7} Android - Spins during pairing
#40

Thanks!
Is there a bug ID/issue we can track on this, or is it internal only?


#41

I was having the same issue. By manually pairing my Boron to my phone (via the phone’s bluetooth setup) and then restarting the Particle app, I was able to then set it up with my phone (Pixel 2, Android 8.0).


#42

@mchinand can you make a short video of this? I don’t think it’s possible to actually pair with our devices like that, so I wonder if I’m misunderstanding here (or maybe you’re getting the device to do something I couldn’t? :slight_smile: )


#43

@mchinand @jensck When I try to manually pair it with my phone I get a message that it was rejected. Which is what I’m assuming the qrcode scanning part is for. I think there is definitely something the developers will have to work out. I’m going to try with a different device this evening and let you know the results.


#44

I’ll try to repeat the process I did and make a video of it; not sure I’ll get to it tonight. How do I reset my Boron to a fresh state? I’ll clear the cache and data from the Particle app too. Anything else I should do to start in a clean state? Also, I don’t think my Boron remained connected to my phone when I initiated the pairing from the phone From @cparticle 's reply, maybe it didn’t ever successfully connected, I didn’t get an error though and was able to complete the setup process.


#45

@mchinand the process doesn’t rely on any mutable state that I’m aware of, but to be safe, you can reset the Boron by holding MODE, tapping RESET, and then continuing to hold MODE until it starts fast flashing white (around 8 seconds)

Thanks!


#46

The connecting to bluetooth from the phone settings appears to have been a red herring. I tried to make a video of what I did previously but couldn’t replicate it. I was finally able to connect and complete the setup after several tries though. A couple times waiting 5+ minutes to see if it would connect, but after that, waiting no more than about a minute before retrying.


#47

I am trying to setup my Boron LTE. It is pairing with the iOS app, after the selection of the “Use in Mesh Network” - it fails with a pop up “Something went wrong with Bluetooth”.

I tried with the Particle CLI - following works

particle identify
particle flash usb <hbrid bin file> 

but the following does not

particle setup
particle device add <device id>

was trying out the whole weekend and today too… any suggestions would help me. feel like kind of stuck.
thanks
Dom


#48

CLI does not support all the commands for Mesh devices yet.

  1. Did you flash the rc25 hybrid bin?
  2. Can you do a particle serial identify to get your sim card information?
  3. Which phone model are you using which is facing Bluetooth issues?

I could walk you through the manual setup and hopefully you are unblocked.


#49

Hello Kenneth,
I did flash the hybrid-0.8.0-rc.25-boron.bin - this worked
I can do a particle serial identify - I get an ID 24 char HEX String
I am using iPhone 7 with iOS ver 12.0.1

yes, any help would be appreciated
thanks
Dom


#50

Is this a typo or are you really missing the -- in what should be particle flash --usb <hbrid.bin> -v? (I’d always add the -v switch to get a more verbose output)


#51

Hi Scruff,
I was able to flash the bin file… just a typo writing it here on the forum. I used the command as you said
particle flash --usb

But I was not able to claim or continue the setup with the app on iOS

thanks
Dom


#52
  1. Place the Boron in Listening Mode (blinking blue)

  2. run the command:

    $ particle serial identify
    
    Your device id is 23402384x92380x993js39u93
    Your IMEI is 0987654321
    Your ICCID is 1234567890
    Your system firmware version is 0.8.0-rc.25
    
  3. Copy the ICCID and go to https://setup.particle.io/

  4. Click on Activate a Particle SIM right at the bottom of the page

  5. Paste the ICCID and hit NEXT

  6. The SIM should be activated

  7. Go to https://console.particle.io/sims and see that the SIM status is Active

  8. Copy the following code and save exit_listening_mode.ino

    #include "dct.h"
    
    SYSTEM_MODE(MANUAL);
    
    void setup() {
        pinMode(D7, OUTPUT);
        digitalWrite(D7, LOW);
    
        const uint8_t val = 0x01;
        dct_write_app_data(&val, DCT_SETUP_DONE_OFFSET, 1);
    
        // This is just so you know the operation is complete
        digitalWrite(D7, HIGH);
    }
    
    void loop() {
    }
    
  9. Compile the app for Boron using:

    $ particle compile boron exit_listening_mode.ino --saveTo boron_exit_listening_mode.bin --target 0.8.0-rc.25

  10. Place the device in DFU mode, flash this binary using:

    $ particle flash --usb boron_exit_listening_mode.bin
    
  11. Hit the RST button and see that D7 LED lights up

  12. Place the Boron in DFU mode

  13. Download tinker-0.8.0-rc.25-boron.bin from https://github.com/particle-iot/firmware/releases/tag/v0.8.0-rc.25-mesh

  14. Do a particle flash --usb tinker-0.8.0-rc.25-boron.bin

  15. Hit RST button and the Boron should blink green and eventually breathing cyan


Sorry for the lengthy steps but I hope this sheds some light on why :particle: spent lots of effort getting the Mobile app + BLE working in the background.

There’s folks who are having issues with BLE and I hope we have that resolved soon to have a smooth onboarding process!


Boron can't connect to cloud
#53

Hi Kenneth,
I do not get an ICCID. I only get these two lines,

C:>particle serial identify

Your device id is e00fceXXXXXXXXXXXXXXXXXX
Your system firmware version is 0.8.0-rc.25

C:>particle help
I do not see the IMEI or ICCID … I am using a non-particle SIM card… 2G/3G is fine for the moment
Regards
Dom