Unable to connect new devices from Particle app using Samsung devices

Hello community

Not sure if this topic should be in troubleshooting.
I am unable to connect new Photon devices from Particle app running on Samsung S6 with Android version 7.0 and latest update 2.3.1
This happened ever since the 2.3.1 update which incorporated the Mesh devices.
I can connect using an older Samsung GT-N5110 tablet running Particle 2.2.2 on Android version 4.4.2

1 Like

Hey eLumaLite,

Would you be able to describe in more detail the issue you are having with connecting new devices?

We did experience a brief issue with the connecting of new Photons from the Particle app with the mesh update that was released during our Spectra conference. (I believe this would have been 2.3.0). This version of the app made it unable to detect SSIDs for Photon devices, thus you could not pick a device to set up.

This should have been resolved in 2.3.1, as 2.3.1 was a bugfix release to resolve that bug.

Thanks for that info Mathew.
In more detail after pressing ready it can find the new Photons(tried 3), but then cant find the AP and gives an error. I dont remember the error as I am away from home. Will need to check and get back to you.
To be honest I did have difficulties similar to this in the past with an older version again on the S6 months ago. Dont remember exactly when though.

1 Like

Hello eLuma,

When you have a chance, I do welcome you to share it with us to see if we can’t get to the bottom of it.

We are undergoing some more application updates for our upcoming mesh release, so there might be some fixes for the issue you are experiencing as well.

I would recommend updating to the latest version and attempting the steps again to see if the issue persists.


Sorry for the late reply.
Here a few screenshots of the setup.


I’m having the same issue on Samsung Galaxy S7 with the newest app. I have updated the app, and uninstalled and reinstalled, and still getting this same error.

1 Like

@KyleG can you point us in the right direction?

Getting the same issue with samsung s7 and s8… Has this issue been looked at by particle? Both running android 8.0.0. Same setup error as person above


This is probably related to my issue where I can’t pair with my new device

1 Like

Same for me on an S9, S8, S7 and Samsung Tab on Particle App 2.3.4.

1 Like

As I also have the issue on my S6, I am using an old Samsung Galaxy Note 8.0 GT-N5110 running Particle 2.2.2 to run setup on Photons.
Perhaps @mstanley can look into this, as it looks like everyone using Samsung devices are encountering this hiccup on Particle 2.3.4.


Emil, can you confirm whether or not the issue is occurring on Samsung device?

I did reach out to our mobile team a few weeks ago regarding the issue, but haven’t heard back just yet.

Incidentally, I actually just upgraded my personal device. While I was unable to reproduce this issue on my LG V20, I was able to run into this issue just recently while using my Galaxy Note 8.

So you may be onto something regarding it being Samsung specific.

I’ll ping our mobile team again but I’m not sure when they’ll be able to respond, as Thanksgiving holiday is coming up soon.

I’ll be able to test the setup process on a Samsing Note 9 as soon as the devices arrive this week.

There has been discussion about this for close to 2 weeks, with several posts concerning this on Samsung devices.

Indeed. Unfortunately, with resources being spread as thin as they are over mesh–and the app receiving reasonably frequent updates for Mesh, it can sometime prove difficult to determine where the issue originated. Further adding in that Samsung tends to delay the release of newer Android versions a bit and some phones are likely seeing newer updates, there’s nothing discounting that they may not be introduced in these new versions.

I have a few old Note 4s on Android 5 lying around that never seemed to experience this issue, so I suspect it could be something that’s more recent in the Android ecosystem.

Needless to say, as it is an ongoing and concerning problem that’s impacting our community, we are addressing it. It may require our mobile team getting a few more Samsung devices in the hands to really nail down this issue

In the meantime, for anyone who is having this issue, if they have a non Samsung device available, the process should still go through fine. If that isn’t an option, there is always the CLI as a plan B.

Yeah it’s Samsung Galaxy S6.

I was able to connect with a different android devices (nexus 6p, nexus 5x). To me it seems like a newer Samsung firmware issue.

1 Like

My S9 just updated to the latest Android version from Verizon. Still having the problem.
Android version 8.0.0
Samsung Experience version 9.0
Android security patch level November 1, 2018

I have the same problem using the Cloud SDK for my product, based on https://github.com/particle-iot/spark-setup-android
Some changes occurred in it about a month ago.

I’ve not had time to try and roll back to earlier code to see if that makes a difference.

1 Like

v0.6.2 of the device setup library has been released, which contains the fix for this, and an updated app version will be in the Play Store later today.

Please let us know if you’re still having any trouble!